This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283932 - openstack command issue InsecurePlatformWarning warning
openstack command issue InsecurePlatformWarning warning
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
medium Severity low
: async
: 8.0 (Liberty)
Assigned To: Jakub Ruzicka
Shai Revivo
: ZStream
Depends On: 1227505
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 05:15 EST by Pablo Caruana
Modified: 2017-02-28 19:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-28 19:42:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1227505 None None None 2016-09-01 03:59 EDT

  None (edit)
Description Pablo Caruana 2015-11-20 05:15:53 EST
When running openstack commands on a RHEL7 machine, using HTTPS URL:s to the services, every command starts with a warning:

/usr/lib/python2.7/site-packages/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
  InsecurePlatformWarning

According to the web page referred, this seems to be a problem that has been fixed in a later version. 

python-openstackclient-1.0.3-2.el7.noarch
pyOpenSSL-0.13.1-3.el7.x86_64
Comment 2 Pablo Caruana 2015-11-20 05:22:45 EST
Similar messages happens with OSP7 Bug 1242675 " When the undercloud is configured with SSL=true any Cli command produce multiple SSL SecurityWarning. (edit) "
	
If using the package python-ndg_httpsclient from EPEL makes these warnings go away so basically the workaround is:

export PYTHONWARNINGS="ignore:Certificate has no, ignore:A true SSLContext object is not available"
Comment 6 Jakub Ruzicka 2016-08-22 07:29:05 EDT
This warning isn't present in RDO with pyOpenSSL-0.15.1-1.el7ost, can we add that (or higher) to OSP?
Comment 7 Robin Cernin 2016-08-29 07:35:02 EDT
If we talk about the pyOpenSSL this package is shipped with the current RHEL Server repositories and [latest] in the pyOpenSSL package is 0.13.1-3.el7. then we need to negotiate on adding this package to current RHEL Server repo. Not the OSP one.
Comment 8 Robin Cernin 2016-09-01 03:59:10 EDT
Issues which blocks pyOpenSSL-0.15.1-1.el7ost being shipped yet with RHEL
Comment 9 Alan Pevec 2017-02-28 19:42:09 EST
not openstackclient issue

Note You need to log in before you can comment on or make changes to this bug.