Bug 1283941 - Operating System description is shown in name column
Operating System description is shown in name column
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.4
x86_64 All
unspecified Severity high (vote)
: 6.1.6
: --
Assigned To: Ohad Levy
Tazim Kolhar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 06:07 EST by Oleksandr Shtaier
Modified: 2017-02-23 14:40 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The operating system description was shown in the name column, leading to customer confusion. The correct value is now shown.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 02:42:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with issue on UI (89.60 KB, image/png)
2015-11-20 06:07 EST, Oleksandr Shtaier
no flags Details
description entity (58.14 KB, image/png)
2016-01-05 06:46 EST, Tazim Kolhar
no flags Details
the coloum is still not correct (58.14 KB, image/png)
2016-01-08 04:21 EST, Tazim Kolhar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12554 None None None 2016-04-22 13:01 EDT

  None (edit)
Description Oleksandr Shtaier 2015-11-20 06:07:34 EST
Created attachment 1097101 [details]
Screenshot with issue on UI

Description of problem:
If you create new operating system without description - application has correct behavior and you can see that new OS name in name column and hosts count in hosts column. But if you specify any description for operating system, so that description will be displayed in name column instead OS name. That is even more confusing when you use search functionality and search for OS with "name='AAAA'", but get entity with name='BBBB'

Version-Release number of selected component (if applicable):
Hard to tell when that issue was introduced

How reproducible:
Always

Steps to Reproduce:
1. Create new operating system (Hosts->Operating systems) with description

Actual results:
You see entity description in name column

Expected results:
You see entity name in name column

Additional info:
Comment 2 Og Maciel 2015-11-20 13:50:12 EST
Created redmine issue http://projects.theforeman.org/issues/12554 from this bug
Comment 3 Bryan Kearney 2015-12-07 12:07:09 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12554 has been closed
-------------
Anonymous
Applied in changeset commit:6308a7ba6ae36a7b12174692bd2759c7a33a2c4f.
Comment 5 Tazim Kolhar 2016-01-05 06:43:20 EST
FAILEDQA:

 rpm -qa | grep foreman
dell-pe1950-05.rhts.eng.brq.redhat.com-foreman-client-1.0-1.noarch
dell-pe1950-05.rhts.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
puppet-foreman_scap_client-0.3.3-10.el7sat.noarch
foreman-vmware-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-ovirt-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.24-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.10-1.el7sat.noarch
foreman-debug-1.7.2.50-1.el7sat.noarch
foreman-proxy-1.7.2.8-1.el7sat.noarch
dell-pe1950-05.rhts.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-discovery-image-3.0.5-3.el7sat.noarch
foreman-libvirt-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_openscap-0.3.2.10-1.el7sat.noarch
foreman-gce-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.15-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.23-1.el7sat.noarch
foreman-selinux-1.7.2.17-1.el7sat.noarch
foreman-postgresql-1.7.2.50-1.el7sat.noarch
foreman-compute-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.14-1.el7sat.noarch


steps:
1. Create new operating system (Hosts->Operating systems) with description

You still see entity description in name column

screenshot attached
Comment 6 Tazim Kolhar 2016-01-05 06:46 EST
Created attachment 1111805 [details]
description entity
Comment 7 Bryan Kearney 2016-01-06 12:27:27 EST
Moving to add to the errata.
Comment 8 Tazim Kolhar 2016-01-08 04:20:01 EST
FAILEDQA:
# rpm -qa | grep foreman
hp-dl120g6-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
puppet-foreman_scap_client-0.3.3-10.el7sat.noarch
foreman-vmware-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-ovirt-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.24-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.10-1.el7sat.noarch
foreman-debug-1.7.2.50-1.el7sat.noarch
foreman-proxy-1.7.2.8-1.el7sat.noarch
hp-dl120g6-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-discovery-image-3.0.5-3.el7sat.noarch
foreman-libvirt-1.7.2.50-1.el7sat.noarch
foreman-postgresql-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_openscap-0.3.2.10-1.el7sat.noarch
foreman-gce-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.15-1.el7sat.noarch
hp-dl120g6-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
ruby193-rubygem-foreman_discovery-2.0.0.23-1.el7sat.noarch
foreman-selinux-1.7.2.17-1.el7sat.noarch
foreman-compute-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.14-1.el7sat.noarch

steps:
1. Create new operating system (Hosts->Operating systems) with description

You still see entity description in name column

screenshot attached
Comment 9 Tazim Kolhar 2016-01-08 04:21 EST
Created attachment 1112788 [details]
the coloum is still not correct
Comment 10 Mike McCune 2016-01-11 20:01:46 EST
This change is slightly confusing, we actually do show the name *OR* description but will show the description if the description is set in the title column. We don't have a "Name" column in the list, note that it is called TITLE which is derived from Name OR Description with description taking precedence.

Test should be:

1) Create an OS entry with only a Name set, ensure the name shows in the TITLE column of the list

2) Create an OS entry with a Name and Description where the Description is different from the name. Ensure the Description is shown in the TITLE column of the UI
Comment 11 Oleksandr Shtaier 2016-01-12 04:26:44 EST
Sorry, it was my overall misunderstanding and actually after bunch of discussions with devs I got some good reasons to have 'description' value instead 'name' value as we have same logic across all application for Operation System entity, so next verification steps should be used for that defect:

1) Make sure that 'Name' column was renamed on 'Title'
2) Make sure that 'New Operating System' dialog has 'OS friendly name; e.g. RHEL 6.5' hint of 'description' field instead 'e.g. RHEL 6.5'
Comment 12 Tazim Kolhar 2016-01-12 07:43:56 EST
VERIFIED:
# rpm -qa | grep foreman
dell-pe-sc1435-02.rhts.englab.brq.redhat.com-foreman-proxy-1.0-1.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
foreman-vmware-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-ovirt-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.24-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.10-1.el7sat.noarch
foreman-debug-1.7.2.50-1.el7sat.noarch
foreman-proxy-1.7.2.8-1.el7sat.noarch
foreman-postgresql-1.7.2.50-1.el7sat.noarch
dell-pe-sc1435-02.rhts.englab.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-libvirt-1.7.2.50-1.el7sat.noarch
foreman-gce-1.7.2.50-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.15-1.el7sat.noarch
dell-pe-sc1435-02.rhts.englab.brq.redhat.com-foreman-client-1.0-1.noarch
ruby193-rubygem-foreman_discovery-2.0.0.23-1.el7sat.noarch
foreman-selinux-1.7.2.17-1.el7sat.noarch
foreman-compute-1.7.2.50-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.4-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.14-1.el7sat.noarch

steps:
1) Create an OS entry with only a Name set, ensure the name shows in the TITLE column of the list

2) Create an OS entry with a Name and Description where the Description is different from the name. Ensure the Description is shown in the TITLE column of the UI
Comment 15 errata-xmlrpc 2016-01-21 02:42:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0052

Note You need to log in before you can comment on or make changes to this bug.