Bug 1283948 - glupy default CFLAGS conflict with our CFLAGS when --enable-debug is used
glupy default CFLAGS conflict with our CFLAGS when --enable-debug is used
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 06:24 EST by Raghavendra Talur
Modified: 2016-06-16 09:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:45:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2015-11-20 06:24:55 EST
Description of problem:

    We use python-config in glupy section of configure.ac
    to get recommended CFLAGS.
    It provides -D_FORTIFY_SOURCE=2 by default that
    conflicts with our --enable-debug option which has -O0.



How reproducible:
Always


Steps to Reproduce:
1. use --enable-debug on fedora 23 or RHEL 7 and make sure glupy is enabled during configure.
2. make

Actual results:
Build fails with error 
In file included from /usr/include/ctype.h:26:0,
                 from /home/jenkins/glusterfs/xlators/features/glupy/src/glupy.c:11:
/usr/include/features.h:330:4: error: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
 #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)



Expected results:
Build should succeed.
Comment 1 Vijay Bellur 2015-11-20 06:31:15 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 05:29:16 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Vijay Bellur 2016-01-12 04:40:44 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 4 Vijay Bellur 2016-01-18 15:54:47 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#4) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 5 Vijay Bellur 2016-01-18 15:54:50 EST
REVIEW: http://review.gluster.org/13256 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 6 Vijay Bellur 2016-01-18 16:01:37 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#5) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 7 Vijay Bellur 2016-01-18 16:48:38 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#6) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 8 Vijay Bellur 2016-01-20 08:54:42 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#7) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 9 Vijay Bellur 2016-01-21 01:33:38 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#8) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 10 Vijay Bellur 2016-01-21 01:34:45 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#9) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 11 Vijay Bellur 2016-01-25 14:21:57 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#10) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 12 Vijay Bellur 2016-01-25 14:31:47 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#11) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 13 Vijay Bellur 2016-01-25 14:37:49 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#12) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 14 Vijay Bellur 2016-01-25 14:46:44 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#13) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 15 Vijay Bellur 2016-01-25 15:01:54 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#14) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 16 Vijay Bellur 2016-01-25 16:00:27 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#15) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 17 Vijay Bellur 2016-01-27 05:24:32 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#16) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 18 Vijay Bellur 2016-01-27 05:55:26 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#17) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 19 Vijay Bellur 2016-01-27 13:42:04 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#18) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 20 Vijay Bellur 2016-02-09 09:43:35 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#19) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 21 Vijay Bellur 2016-02-09 10:16:51 EST
REVIEW: http://review.gluster.org/12707 (build: Filter -D_FORTIFY_SOURCE from CFLAGS) posted (#20) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 22 Vijay Bellur 2016-02-10 01:27:10 EST
COMMIT: http://review.gluster.org/12707 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 5e65701f2660d1be101da81bffea7721d4f9ece0
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Fri Nov 20 16:46:31 2015 +0530

    build: Filter -D_FORTIFY_SOURCE from CFLAGS
    
    We use python-config to get recommended CFLAGS. It provides
    -D_FORTIFY_SOURCE=2 by default that conflicts with our
    --enable-debug option or a developer provided no-optimization option.
    Hence, filter it out from default CFLAGS.
    
    Change-Id: Id80196baeb55415b1ea334e7b17143e56dfbadb3
    BUG: 1283948
    Co-authored-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/12707
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 23 Mike McCune 2016-03-28 19:30:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 24 Niels de Vos 2016-06-16 09:45:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.