Bug 1283950 - [regression] [wayland] gdk_wayland_window_show() is broken (was: [abrt] gnome-builder: gdk_wayland_window_show(): gnome-builder killed by SIGSEGV)
[regression] [wayland] gdk_wayland_window_show() is broken (was: [abrt] gnome...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c143eb106a2beb6ab19fe568a09...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 06:28 EST by Christian Stadelmann
Modified: 2015-12-17 20:40 EST (History)
7 users (show)

See Also:
Fixed In Version: gtk3-3.18.5-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 20:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (70.47 KB, text/plain)
2015-11-20 06:28 EST, Christian Stadelmann
no flags Details
File: core_backtrace (8.82 KB, text/plain)
2015-11-20 06:28 EST, Christian Stadelmann
no flags Details
File: dso_list (24.34 KB, text/plain)
2015-11-20 06:28 EST, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-20 06:28 EST, Christian Stadelmann
no flags Details
File: maps (108.62 KB, text/plain)
2015-11-20 06:29 EST, Christian Stadelmann
no flags Details
File: namespaces (85 bytes, text/plain)
2015-11-20 06:29 EST, Christian Stadelmann
no flags Details
File: open_fds (5.77 KB, text/plain)
2015-11-20 06:29 EST, Christian Stadelmann
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-11-20 06:29 EST, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-11-20 06:28:47 EST
Description of problem:
I deleted a word that was currently highlighted due to being a search result inside an xml document.

Steps to reproduce:
1. clone https://github.com/timlau/yumex-dnf (as of today, 2015-11-20)
2. open project in gnome-builder
3. open src/yumex.ui inside gnome-builder
4. search for "font". gnome-builder finds xml tag with name="font-desc", "font" is highlighted
5. delete "font-desc" (without deleting "") and write something else, e.g. "scale"

Then gnome-builder crashes.

I can reproduce this issue with other XML documents too. I cannot reproduce this issue with gedit or when editing python (.py) files in gnome-builder.

Version-Release number of selected component:
gnome-builder-3.18.1-2.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/gnome-builder --gapplication-service
crash_function: gdk_wayland_window_show
executable:     /usr/bin/gnome-builder
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 gdk_wayland_window_show at gdkwindow-wayland.c:1279
 #3 gdk_window_show_internal at gdkwindow.c:5013
 #4 gtk_window_map at gtkwindow.c:6096
 #5 _g_closure_invoke_va at gclosure.c:864
 #8 gtk_widget_map at gtkwidget.c:4920
 #9 gtk_window_show at gtkwindow.c:5952
Comment 1 Christian Stadelmann 2015-11-20 06:28:53 EST
Created attachment 1097106 [details]
File: backtrace
Comment 2 Christian Stadelmann 2015-11-20 06:28:55 EST
Created attachment 1097107 [details]
File: core_backtrace
Comment 3 Christian Stadelmann 2015-11-20 06:28:56 EST
Created attachment 1097108 [details]
File: dso_list
Comment 4 Christian Stadelmann 2015-11-20 06:28:58 EST
Created attachment 1097109 [details]
File: limits
Comment 5 Christian Stadelmann 2015-11-20 06:29:00 EST
Created attachment 1097110 [details]
File: maps
Comment 6 Christian Stadelmann 2015-11-20 06:29:01 EST
Created attachment 1097111 [details]
File: namespaces
Comment 7 Christian Stadelmann 2015-11-20 06:29:03 EST
Created attachment 1097112 [details]
File: open_fds
Comment 8 Christian Stadelmann 2015-11-20 06:29:04 EST
Created attachment 1097113 [details]
File: proc_pid_status
Comment 9 Christian Stadelmann 2015-11-20 06:52:28 EST
I was wrong before, this crasher also happens in .py files.
And it happens in xml files without a previous search too.
Comment 10 Christian Stadelmann 2015-11-20 06:57:25 EST
This issue seems to be caused when gnome-builder tries to display a small window for showing code completion suggestions. I guess it is specific to wayland.
Comment 11 Christian Stadelmann 2015-11-20 07:00:38 EST
This issue is a regression to Gtk3 3.18.2 on Fedora 23.
Comment 12 Kalev Lember 2015-11-20 12:27:57 EST
Thanks, should be fixed in gtk3-3.18.5-3.fc23
Comment 13 Fedora Update System 2015-11-21 06:27:42 EST
gtk3-3.18.5-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a95ea0626
Comment 14 Fedora Update System 2015-11-22 09:25:10 EST
gtk3-3.18.5-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update gtk3'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4a95ea0626
Comment 15 Fedora Update System 2015-11-23 15:53:20 EST
gtk3-3.18.5-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Christian Stadelmann 2015-11-27 19:37:54 EST
Sorry, this fix is just avoiding the crash but still makes the popup window not appear at all. gnome-builder's code completion doesn't work any more with gtk3-3.18.5-3.fc23.
Comment 17 jibecfed 2015-11-28 05:56:06 EST
Same problem in here, no crash but still not working
Comment 18 Matthias Clasen 2015-12-17 20:40:36 EST
thats an unrelated problem, and not related to the original issue

Note You need to log in before you can comment on or make changes to this bug.