Bug 1283970 - perl-MooseX-Types-DateTime-ButMaintained-0.16-10.fc24 FTBFS: test fails: Attribute (loc) does not pass the type constraint because: Validation failed for 'DateTime::Locale' with value DateTime::Locale::FromData=HASH(0x21d0080) (not isa DateTime::Locale::r
perl-MooseX-Types-DateTime-ButMaintained-0.16-10.fc24 FTBFS: test fails: Attr...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-MooseX-Types-DateTime-ButMaintained (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 07:19 EST by Petr Pisar
Modified: 2015-11-24 05:24 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-MooseX-Types-DateTime-ButMaintained-0.16-11.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 05:24:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 108686 None None None Never

  None (edit)
Description Petr Pisar 2015-11-20 07:19:10 EST
perl-MooseX-Types-DateTime-ButMaintained-0.16-10.fc24 fails to build in F24 because tests fail:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/01_basic.t t/02_olson_abbreviations.t t/03_local_floating.t
Attribute (loc) does not pass the type constraint because: Validation failed for 'DateTime::Locale' with value DateTime::Locale::FromData=HASH(0x21d0080) (not isa DateTime::Locale::root) at /usr/lib64/perl5/vendor_perl/Moose/Object.pm line 24
	Moose::Object::new('Gorch', 'loc', 'he_IL') called at t/01_basic.t line 104
# Looks like your test exited with 255 just after 16.
t/01_basic.t ................ 
Dubious, test returned 255 (wstat 65280, 0xff00)
All 16 subtests passed 

Difference between working and failing build root:

        perl-DateTime-Locale 	0.92-1.fc24 	> 	1.01-1.fc24
	glibc 	2.22.90-13.fc24 	> 	2.22.90-16.fc24
	perl-Carp 	1.36-346.fc23 	> 	1.38-1.fc24
	glibc-common 	2.22.90-13.fc24 	> 	2.22.90-16.fc24
	glibc-devel 	2.22.90-13.fc24 	> 	2.22.90-16.fc24
	glibc-headers 	2.22.90-13.fc24 	> 	2.22.90-16.fc24
	glib2 	2.47.1-1.fc24 	> 	2.47.1-2.fc24
	kernel-headers 	4.4.0-0.rc0.git4.2.... 	> 	4.4.0-0.rc0.git5.1....

Note You need to log in before you can comment on or make changes to this bug.