Bug 1283975 - libarchive FTBFS on 32-bit architectures during stage2 bootstrap - undefined reference to `lzma_*'
libarchive FTBFS on 32-bit architectures during stage2 bootstrap - undefined ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libarchive (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-bootstrap
  Show dependency treegraph
 
Reported: 2015-11-20 07:27 EST by Jaromír Cápík
Modified: 2016-01-31 21:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 05:19:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libarchive.log (29.47 KB, text/plain)
2015-11-20 07:27 EST, Jaromír Cápík
no flags Details
libarchive.log (31.28 KB, text/plain)
2015-11-23 05:04 EST, Jaromír Cápík
no flags Details

  None (edit)
Description Jaromír Cápík 2015-11-20 07:27:04 EST
Created attachment 1097159 [details]
libarchive.log

Description of problem:
During the stage2 bootstrap we experience FTBFS on 32-bit architectures.

---
CCLD   bsdtar
./.libs/libarchive.a(archive_write_add_filter_xz.o): In function `drive_compressor':
/stage2/rpmbuild/BUILD/libarchive-3.1.2/libarchive/archive_write_add_filter_xz.c:477: undefined reference to `lzma_code'
/stage2/rpmbuild/BUILD/libarchive-3.1.2/libarchive/archive_write_add_filter_xz.c:477: undefined reference to `lzma_code'
/stage2/rpmbuild/BUILD/libarchive-3.1.2/libarchive/archive_write_add_filter_xz.c:500: undefined reference to `lzma_memusage'
./.libs/libarchive.a(archive_write_add_filter_xz.o): In function `archive_compressor_xz_close':
/stage2/rpmbuild/BUILD/libarchive-3.1.2/libarchive/archive_write_add_filter_xz.c:433: undefined reference to `lzma_end'
./.libs/libarchive.a(archive_write_add_filter_xz.o): In function `archive_compressor_xz_write':
/stage2/rpmbuild/BUILD/libarchive-3.1.2/libarchive/archive_write_add_filter_xz.c:397: undefined reference to `lzma_crc32'
---

The full log is attached.


Version-Release number of selected component (if applicable):
libarchive-3.1.2-11.fc21


How reproducible:
always
Comment 1 Pavel Raiskup 2015-11-20 07:38:38 EST
Thanks for the report.  Am I able to reproduce 'stage2' somehow?
Comment 2 Pavel Raiskup 2015-11-20 07:42:06 EST
At least it would be fine to know whether (a) autotools are installed, (b)
what are the configure options, (c) what is inside /usr/share/config.site
file, (d) what are the compiler/linker options (make V=1).
Comment 3 Jaromír Cápík 2015-11-20 09:06:19 EST
Ahoj Pavle.
I think I've found the reason why this happens. The liblzma is not built correctly in stage1. Please, let me do a complete rebuild with a fix and if that helps, I'll close this report.
Thanks.
Comment 4 Jaromír Cápík 2015-11-23 05:04 EST
Created attachment 1097607 [details]
libarchive.log
Comment 5 Jaromír Cápík 2015-11-23 05:19:58 EST
The problem seems to be fixed. Closing.

Note You need to log in before you can comment on or make changes to this bug.