Bug 1284047 - ceilometer rpc_backed is deprecated
ceilometer rpc_backed is deprecated
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: rc
: 10.0 (Newton)
Assigned To: Jiri Stransky
Mehdi ABAAKOUK
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 11:13 EST by Derek Higgins
Modified: 2016-12-14 10:18 EST (History)
11 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-14 10:18:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2015-11-20 11:13:22 EST
Description of problem:

On a director deployed ceilometer, we have 
rpc_backend=ceilometer.openstack.common.rpc.impl_kombu

this has been deprecated (and removed in liberty), the correct value is
rpc_backend=rabbit

This must be changed in OSP-8 and ideally before (to simplify upgrades) 

It has been fixed upstream in the ceilometer puppet module
https://review.openstack.org/#/c/196036/

Version-Release number of selected component (if applicable):
openstack-puppet-modules-2015.1.8-29.el7ost.noarch
openstack-ceilometer-common-2015.1.2-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-78.el7ost.noarch
Comment 2 Emilien Macchi 2015-12-01 16:30:58 EST
@Derek: I don't understand the problem.
https://review.openstack.org/#/c/196036/ is in OPM (at least for OSP8, Liberty). You want a backport to OSP7 (Kilo) ?
Comment 3 Derek Higgins 2015-12-04 04:47:18 EST
@Emilien ideally it would be backported to OSP7, the upgrade process involves the package being upgraded and the services being restarted before the new puppet modules get applied. To avoid an error before the new puppet modules are applied we would need the updated value in OSP7.

Alternatively this can be worked around as part of the upgrade process, so I wouldn't call it a blocker by any means.
Comment 7 Mike Burns 2016-02-29 15:31:15 EST
Jirka, are you handling this already? or do we need to track it?
Comment 9 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 12 Mehdi ABAAKOUK 2016-10-20 04:30:49 EDT
Still valid issue:

$ rpm -qa | grep openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-5.0.0-0.20161008015357.0d3e3e3.1.el7ost.noarch

# grep ^rpc_backend /etc/ceilometer/ceilometer.conf
rpc_backend=rabbit

The puppet stuff itself looks good, but:

This is the culprit https://github.com/openstack/tripleo-heat-templates/blob/master/extraconfig/tasks/major_upgrade_controller_pacemaker_1.sh#L181
Comment 13 Jiri Stransky 2016-10-20 05:19:25 EDT
(In reply to Mehdi ABAAKOUK from comment #12)
> # grep ^rpc_backend /etc/ceilometer/ceilometer.conf
> rpc_backend=rabbit

I think that's the correct value though (see comment #0), so should this BZ be marked 'verified' rather? The BZ was breaking update from 7 to 8, and has been fixed back then, otherwise we couldn't update Ceilometer to OSP 8 correctly IIRC.
Comment 14 Mehdi ABAAKOUK 2016-10-20 05:25:22 EDT
Oh yeah sorry I have misreading, so yeah everything is OK.
Comment 17 errata-xmlrpc 2016-12-14 10:18:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.