Bug 1284052 - IPA DNS Zone/DNS Forward Zone details missing after upgrade from RHEL 7.0 to RHEL 7.2
IPA DNS Zone/DNS Forward Zone details missing after upgrade from RHEL 7.0 to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression, ZStream
Depends On: 1283943
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 11:25 EST by Jan Kurik
Modified: 2015-12-08 05:37 EST (History)
9 users (show)

See Also:
Fixed In Version: ipa-4.2.0-15.el7_2.3
Doc Type: Bug Fix
Doc Text:
An internal error during an upgrade prevented the upgrade process from upgrading forward zones properly. Consequently, original forward zones have been removed, but no new (new-style) forward zones were added. Effectively, all forward zones disappeared. This update fixes internal calls of API, and old-style forward zones are now migrated properly.
Story Points: ---
Clone Of: 1283943
Environment:
Last Closed: 2015-12-08 05:37:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-20 11:25:52 EST
This bug has been copied from bug #1283943 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 9 Nikhil Dehadrai 2015-11-25 12:25:52 EST
IPA server details:
------------------
ipa-server-3.3.3-28.el7.x86_64 (Before Update)
ipa-server-4.2.0-15.el7_2.3.x86_64 (After Update)

Tested the bug with following observations:
------------------------------------------------
1. Verified that DNS Zone/Zone Forwarders created before update are present after the update to the latest IPA version (ipa-server-4.2.0-15.el7_2.3.x86_64).

2. Verified that the DNS Zones/ZONE Forwarders after the update to latest IPA version are appropriately migrated based on the migration table. (http://www.freeipa.org/page/V4/Forward_zones#Updates_and_Upgrades)

3. Refer the attachment for console output for steps performed.

Thus , based on above observations marking the status of bug to "VERIFIED".
Comment 13 errata-xmlrpc 2015-12-08 05:37:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2562.html

Note You need to log in before you can comment on or make changes to this bug.