This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1284058 - swift is using deprecated ceilometer middleware
swift is using deprecated ceilometer middleware
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: Triaged
Depends On:
Blocks: 1374871
  Show dependency treegraph
 
Reported: 2015-11-20 11:44 EST by Derek Higgins
Modified: 2016-12-14 10:18 EST (History)
13 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.9.0rc3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, Object Storage service deployed using the director used ceilometer middleware that had been deprecated since the Red Hat OpenStack Platform 8 (liberty) release. With this update, the Object Storage service has been fixed to use the ceilometer middleware from python-ceilometermiddleware which is the supported version for this release.
Story Points: ---
Clone Of:
: 1374871 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:18:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 381250 None None None 2016-10-26 06:34 EDT
OpenStack gerrit 389707 None None None 2016-10-26 06:33 EDT

  None (edit)
Description Derek Higgins 2015-11-20 11:44:14 EST
Description of problem:

On a director deployed swift we are using deprecated ceilometer
middleware that has been dropped in liberty.

We have (in /etc/swift/proxy-server.conf)
[filter:ceilometer]
use = egg:ceilometer#swift

we should be using the middleware provided by the python-ceilometermiddleware package (ceilometermiddleware.swift:filter_factory)

This should be changed in OSP-8 and ideally before (to simplify upgrades) 


upstream we dropped the middleware from the pipeline because the package wasn't available at the time
https://review.openstack.org/#/c/197933/1

now that the package is available for python-ceilometermiddleware we should use it instead.

Version-Release number of selected component (if applicable):
openstack-puppet-modules-2015.1.8-29.el7ost.noarch
openstack-ceilometer-common-2015.1.2-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-78.el7ost.noarch
Comment 3 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Sachin 2016-09-09 05:54:38 EDT
This is the reason why following meters are not displayed/available?

- storage.objects.outgoing.bytes
- storage.objects.incoming.bytes


--
Sachin
Comment 6 Sachin 2016-09-09 06:01:52 EDT
@Hugh, I don't see much activity, are you still working on this bug?
Comment 15 errata-xmlrpc 2016-12-14 10:18:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.