Bug 1284081 - Git (cli tool) incorrectly depends on gnome (libgnome-keyring)
Summary: Git (cli tool) incorrectly depends on gnome (libgnome-keyring)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: git
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: Leos Pol
Marie Dolezelova
URL:
Whiteboard:
Depends On: 1598184
Blocks: 1400961 1465925 1472751
TreeView+ depends on / blocked
 
Reported: 2015-11-20 18:31 UTC by Steven French
Modified: 2018-10-30 11:38 UTC (History)
5 users (show)

Fixed In Version: git-1.8.3.1-16.el7
Doc Type: Bug Fix
Doc Text:
The helper to store credentials in a GNOME keyring is now available in the _git-gnome-keyring_ subpackage Previously, installing *git* automatically installed GNOME components as a dependency, because the helper to store credentials in a GNOME keyring was part of the *git* package. With this update, the helper has been moved into the separate _git-gnome-keyring_ subpackage. As a result, the size of a *git* installation is reduced. To install the subpackage: # yum install git-gnome-keyring
Clone Of:
Environment:
Last Closed: 2018-10-30 11:38:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3275 None None None 2018-10-30 11:38:57 UTC
Red Hat Bugzilla 1213059 None None None Never

Internal Links: 1213059

Description Steven French 2015-11-20 18:31:34 UTC
Description of problem:
simple, common cli tools (git) should not depend on bringing in gnome (in particular git rpm in RHEL7.1 depends on libgnome-keyring)

Version-Release number of selected component (if applicable):


How reproducible:

yum install git

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Stodulka 2015-12-07 16:57:51 UTC
That makes sense.

Comment 3 Eli Young 2016-12-23 01:45:14 UTC
This is a result of the git-core package including git-credential-gnome-keyring. That should probably go into its own package.

Comment 4 Petr Stodulka 2017-01-24 15:54:10 UTC
Eli: yes, this is expected solution.

Comment 5 Petr Stodulka 2017-01-24 15:57:05 UTC
Just one problem is here, that this will be little incompatible change, because some people, who uses gnome-keyrings in git, will have to install manually another sub-package.

Comment 10 Petr Stodulka 2017-09-20 11:16:54 UTC
Move this bug to RHEL-7.6, because there is another bug for change in packaging of the Git that will not be acked for testing for rhel-7.5 and make sense move these two bugs together as both of them can involve requirement for manual installation of new sub-packages by user.

Comment 12 Leos Pol 2018-07-25 11:31:49 UTC
# rpm -q git
git-1.8.3.1-13.el7.x86_64
# rpm -qR git | grep gnome
libgnome-keyring.so.0()(64bit)

# rpm -q git
git-1.8.3.1-18.el7.x86_64
# rpm -qR git | grep gnome
# rpm -q git-gnome-keyring
git-gnome-keyring-1.8.3.1-18.el7.x86_64

Comment 19 errata-xmlrpc 2018-10-30 11:38:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3275


Note You need to log in before you can comment on or make changes to this bug.