Bug 1284085 - atomic-openshift-installer Host Configuration text is confusing
atomic-openshift-installer Host Configuration text is confusing
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Samuel Munilla
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 14:17 EST by Evgheni Dereveanchin
Modified: 2016-07-03 20:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgheni Dereveanchin 2015-11-20 14:17:15 EST
Description of problem:
When running the installer wizard, the host configuration section is confusing as it does not explain what kind of input is expected. There are seemingly unconnected paragraphs of text about what Masters and Nodes do. It is not described however what kind of hostname/IP is expected as input: master, node, or both, or something else.

Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
always

Steps to Reproduce:
1. atomic-openshift-installer install
2. press Y
3. press Enter


Actual results:
following text is displayed:

***Host Configuration***

The OpenShift Master serves the API and web console.  It also coordinates the
jobs that have to run across the environment.  It can even run the datastore.
For wizard based installations the database will be embedded.  It's possible to
change this later using etcd from Red Hat Enterprise Linux 7.

Any Masters configured as part of this installation process will also be
configured as Nodes.  This is so that the Master will be able to proxy to Pods
from the API.  By default this Node will be unscheduleable but this can be changed
after installation with 'oadm manage-node'.

The OpenShift Node provides the runtime environments for containers.  It will
host the required services to be managed by the Master.

http://docs.openshift.com/enterprise/latest/architecture/infrastructure_components/kubernetes_infrastructure.html#master
http://docs.openshift.com/enterprise/latest/architecture/infrastructure_components/kubernetes_infrastructure.html#node
    
Enter hostname or IP address: []: 

Expected results:

Instead of unconnected paragraphs of text - show a description of what this step is actually about: user needs to provide hostnames of all masters/nodes that will take part in the environment that is going to be installed.
Comment 1 Brenton Leanhardt 2015-11-30 14:06:20 EST
This is currently being worked on in this PR:

https://github.com/openshift/openshift-ansible/pull/999/files
Comment 4 Gaoyun Pei 2015-12-09 00:37:43 EST
Verify this bug with atomic-openshift-utils-3.0.18-1.git.0.a3e601b.el7aos.noarch

Some more guidance text about what is expected in the following input and the roles management in Host Configuration:


You must now specify the hosts that will compose your OpenShift cluster.

Please enter an IP or hostname to connect to for each system in the cluster.
You will then be prompted to identify what role you would like this system to
serve in the cluster.

 
If only one Master is specified, an etcd instance embedded within the OpenShift
Master service will be used as the datastore.  This can be later replaced with a
separate etcd instance if desired.  If multiple Masters are specified, a
separate etcd cluster will be configured with each Master serving as a member.
Comment 6 errata-xmlrpc 2015-12-17 16:19:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.