Bug 1284119 - KMix does not save sound device preferences
KMix does not save sound device preferences
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: kmix (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 17:06 EST by Oleg Goldshmidt
Modified: 2016-07-19 15:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:22:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Goldshmidt 2015-11-20 17:06:34 EST
Description of problem:

I have a ThinkPad 450s running fully updated Fedora 22 and KDE (qt5, etc.). The mini-DP port is connected to external monitor (TV) via DP-HDMI connector. The audio jack is connected to an external sound system with speakers.

I am not able to make the sound go to the sound system. I have two devices,

$ lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)

They both show (in kmix and systemsettings5 alike) as Built-In Audio Analog Stereo and Built-in Audio Digital Stereo (HDMI). I have Analog preferred over Digital for everything, but I can't save my preferences in the Audio Hardware Setup tab. Both devices show up as Built-In Audio, but it's obvious which is which. When I pick Analog (+ Profile) and click Apply and OK, nothing changes - no sound. When I re-open the tab (or the KMix Settings) I see HDMI selected again as if I did not change anything. Restarting X or rebooting does not help.

I also tried "xrandr --output HDMI1 --set audio off" and similar, in vain.

How can I select an audio card and save the settings?

Version-Release number of selected component (if applicable):

kmix-15.04.0-1.fc22.x86_64

How reproducible:

Always.

Steps to Reproduce:

1. Open KMix Settings or System Settings -> Multimedia. 

2. Go to Audio Hardware Setup tab. Assume there are two HW devices: Analog and Digital (HDMI).

3. Choose the Analog Device (should be obvious from the associated profile), click Apply and OK, close the tab and/or the window.

4. Reopen the Window/Tab.

Actual results:

HDMI is chosen as if no changes were made. No sound goes to the sound system connected to the audio port. As long as the audio port is connected there is no sound at all.

Expected results:

Chosen settings should be applied. I should have sound through the system connected to the audio port.

Additional info:

1. Everything worked fine before the series of KDE/kf5/qt5/plasma updates starting roughly a week ago (Nov 12-13 onwards). There were much more serious problems with the graphical environment that seem to have been largely fixed. I am confident though that there is no problem with the sound system, and it does seem to be a software issue that has not been fixed yet.

2. ~/.config/kmixrc shows

DefaultCardOnStart=PulseAudio.Playback_Devices.1.default

and then at least 3 entrie with the above prefix, which may be correct but my intuition makes me suspicious:

[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_03.0.hdmi-stereo]
[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2]
[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_1b.0.analog-stereo]

Full contents of the config file:

[Global]                                                                        
AutoUseMultimediaKeys=true
ConfigVersion=3
DefaultCardOnStart=PulseAudio.Playback_Devices.1.default
MasterMixer=PulseAudio::Playback_Devices:1
MasterMixerDevice=alsa_output.pci-0000_00_1b.0.analog-stereo
Menubar=true
MixerIgnoreExpression=Modem
Position=532,183
Size=578,509
Soundmenu.Mixers=PulseAudio::Playback_Devices:1,PulseAudio::Capture_Streams:1,PulseAudio::Capture_Devices:1,PulseAudio::Playback_Streams:1
Visible=false

[Profiles]
PulseAudio::Capture_Devices:1=PulseAudio.Capture_Devices.1.default
PulseAudio::Capture_Streams:1=PulseAudio.Capture_Streams.1.default
PulseAudio::Playback_Devices:1=PulseAudio.Playback_Devices.1.default
PulseAudio::Playback_Streams:1=PulseAudio.Playback_Streams.1.default

[View.PulseAudio.Capture_Devices.1.default.PulseAudio::Capture_Devices:1.alsa_input.pci-0000_00_1b.0.analog-stereo]
Split=false

[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_03.0.hdmi-stereo]
Split=false

[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_03.0.hdmi-stereo-extra2]
Split=false

[View.PulseAudio.Playback_Devices.1.default.PulseAudio::Playback_Devices:1.alsa_output.pci-0000_00_1b.0.analog-stereo]
Split=false

[View.PulseAudio.Playback_Streams.1.default.PulseAudio::Playback_Streams:1.restore:sink-input-by-media-role:event]
Split=false

[View.PulseAudio.Playback_Streams.1.default.PulseAudio::Playback_Streams:1.stream:1]
Split=false
Comment 1 Oleg Goldshmidt 2015-11-21 07:15:44 EST
Same issue with Dell Latitude E7440 with

$ lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
Comment 2 Fedora End Of Life 2016-07-19 15:22:36 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.