Bug 1284124 - [RFE][spine-leaf] Use a DHCP Helper with the OSP Director
[RFE][spine-leaf] Use a DHCP Helper with the OSP Director
Status: POST
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: Upstream M2
: 13.0 (Queens)
Assigned To: Dan Sneddon
Arik Chernetsky
: FutureFeature, OtherQA, Triaged
Depends On:
Blocks: 1214284 1442136
  Show dependency treegraph
 
Reported: 2015-11-20 17:42 EST by Jeremy
Modified: 2017-11-03 14:00 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 421009 None None None 2017-03-08 13:54 EST
OpenStack gerrit 436716 None None None 2017-02-22 06:38 EST
OpenStack gerrit 437544 None None None 2017-03-22 13:51 EDT
OpenStack gerrit 438171 None None None 2017-03-21 14:37 EDT
OpenStack gerrit 447214 None None None 2017-03-21 14:38 EDT

  None (edit)
Description Jeremy 2015-11-20 17:42:42 EST
Description of problem:
We need to have the OpenStack Platform Director (undercloud) in a separate layer 2 network from it's overcloud provisioning interfaces. We would like to accomplish this by using a DHCP Helper to forward overcloud discovery and provisioning DHCP requests, to the undercloud.

We have attempted the use of a DHCP Helper, but it seems that the discovery; introspection image does not correctly handle configuring a default gateway on an overcloud provisioning interface, even when a gateway is supplied (by a modified ironic discovery dnsmasq configuration). We see the "router" DHCP option sent to the discovery image, yet the discovery image does not configure the provisioning interface with a default gateway - it can not reach the (separated) undercloud.

Version-Release number of selected component (if applicable):



Additional info:
Comment 3 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Note You need to log in before you can comment on or make changes to this bug.