Bug 1284153 - SELinux is preventing pmlogger from 'open' accesses on the file /var/lib/pcp/config/pmlogger/config.default.
SELinux is preventing pmlogger from 'open' accesses on the file /var/lib/pcp/...
Status: CLOSED DUPLICATE of bug 1256125
Product: Fedora
Classification: Fedora
Component: pcp (Show other bugs)
23
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Nathan Scott
Fedora Extras Quality Assurance
abrt_hash:ce682194be3ac878abb41cd0aed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 23:44 EST by Martín Cigorraga
Modified: 2015-12-14 01:53 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 01:53:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martín Cigorraga 2015-11-20 23:44:52 EST
Description of problem:
SELinux is preventing pmlogger from 'open' accesses on the file /var/lib/pcp/config/pmlogger/config.default.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/var/lib/pcp/config/pmlogger/config.default default label should be pcp_var_lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /var/lib/pcp/config/pmlogger/config.default

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that pmlogger should be allowed open access on the config.default file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep pmlogger /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:pcp_pmlogger_t:s0-s0:c0.c1023
Target Context                system_u:object_r:tmp_t:s0
Target Objects                /var/lib/pcp/config/pmlogger/config.default [ file
                              ]
Source                        pmlogger
Source Path                   pmlogger
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-154.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.6-300.fc23.x86_64 #1 SMP Tue
                              Nov 10 19:32:21 UTC 2015 x86_64 x86_64
Alert Count                   4
First Seen                    2015-11-21 00:10:19 ART
Last Seen                     2015-11-21 01:25:08 ART
Local ID                      c6d2ea67-400f-4de0-88f2-d36e9e8e6507

Raw Audit Messages
type=AVC msg=audit(1448079908.833:1509): avc:  denied  { open } for  pid=31879 comm="pmlogger" path="/var/lib/pcp/config/pmlogger/config.default" dev="dm-0" ino=249959 scontext=system_u:system_r:pcp_pmlogger_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=file permissive=0


Hash: pmlogger,pcp_pmlogger_t,tmp_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-154.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.6-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1256125
Comment 1 Lukas Vrabec 2015-11-23 09:24:40 EST
Do you know which process creating this file?
Comment 2 Martín Cigorraga 2015-11-23 10:43:00 EST
Hi Lukas,

I'm not sure, would need to implement some type of directory monitoring to find that but I would think that it might be related with Cockpit as that's the only software I have installed I'm aware of that uses that functionality to store system usage metrics...

I'm not sure how to proceed with this ticket now, should it be put in stand-by or just closed - so when/if this happen again in the future I create a new one?

Thanks for your time.
Comment 3 Lukas Vrabec 2015-11-24 06:51:26 EST
Same issue like #1256125.
Comment 4 Nathan Scott 2015-12-14 01:53:10 EST
Marking as a duplicate, fix will be in pcp-3.10.9.

*** This bug has been marked as a duplicate of bug 1256125 ***

Note You need to log in before you can comment on or make changes to this bug.