Bug 128416 - Not using %find_lang
Not using %find_lang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libexif (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Marco Pesenti Gritti
: EasyFix
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-07-22 13:43 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-09 06:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (1.71 KB, patch)
2004-07-22 13:43 EDT, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2004-07-22 13:43:12 EDT
Description of problem:
The current libexif package doesn't use the %find_lang to properly
color the language files.

Version-Release number of selected component (if applicable):
libexif-0.5.12-3

Additional info:
Attached is a patch to correct this, as well as other minor things :
- Remove redundant name in summary
- Add pkgconfig dependency to the devel package
- Add %{?_smp_mflags} make parameter
- Add docs, including the mandatory COPYING file
Comment 1 Matthias Saou 2004-07-22 13:43:35 EDT
Created attachment 102153 [details]
Spec file patch
Comment 3 Matthias Saou 2004-08-30 14:34:40 EDT
Ping? One month after the initial report, this EasyFix which even
includes a complete patch to the spec and was put in the FC3 Target
Tracker list, isn't resolved yet :-/

Did it get missed? Could a quick patch and rebuild take place?
Comment 4 Elliot Lee 2004-08-30 14:41:04 EDT
(Chris is probably busy with his other bugs at the moment)

FWIW, requiring: pkgconfig for the devel subpackage is incorrect -
although the devel subpackage provides a .pc file, that does not mean
that the devel subpackage requires pkgconfig in order to function.
Comment 5 Matthias Saou 2004-09-29 07:16:01 EDT
Could this be at least be partly applied before the final FC3 freeze?
IMHO, it really is an EasyFix, and if any part of the patch to the
spec isn't to the taste of the maintainer, then it can be dropped, I
really won't mind.

For the pkgconfig Requires: in the devel package, I understand that it
isn't typically a mandatory dependency, but I really think it's a good
thing if the "usual and recommended" way of recompiling against the
software is by using pkgconfig. As an example, gtk2-devel depending on
pkgconfig has spared a huge amount of failed builds and bug reports
for sure. Of course things can be argued both ways... and I'd argue
the other for kernel-sourcecode's dependencies on qt-devel and
gtk2-devel for instance, as "make menuconfig" is still quite common...
oops, getting OT here :-)
Comment 6 Matthias Saou 2004-10-21 05:09:34 EDT
Doh! Still not in, and the final freeze has happened. Too bad,
expecially since it's an EasyFix...
Comment 7 Marco Pesenti Gritti 2004-11-08 15:06:25 EST
Sorry for the delay :/ I'm going to commit this tomorrow, expect the
pkgconfig bit.
Comment 8 Marco Pesenti Gritti 2004-11-09 03:50:52 EST
I applied this one in devel. What was the user visible impact of not
using find_lang? To decide if it's worth an FC3 update ...
Comment 9 Matthias Saou 2004-11-09 05:50:33 EST
Believe it or not, I'm not even sure. I thought at one point that it
was for rpm to skip the install of the language files that didn't
match the languages that the system was configured for (languages
selection at install time), but practise has proved this wrong, at
least on FC.
I'll guess I'll go ask jbj out of curiosity. One thing's sure though :
It's definitely not worth pushing an errata ;-)
Comment 10 Marco Pesenti Gritti 2004-11-09 06:15:29 EST
Updated in RHEL4 too

Note You need to log in before you can comment on or make changes to this bug.