Bug 1284178 - evince does not work anymore
evince does not work anymore
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 09:09 EST by Frank Ansari
Modified: 2015-11-22 11:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 11:13:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error message (25.29 KB, image/png)
2015-11-21 09:09 EST, Frank Ansari
no flags Details

  None (edit)
Description Frank Ansari 2015-11-21 09:09:49 EST
Created attachment 1097467 [details]
screenshot of error message

Description of problem:
When I try to open a pdf file evince will not show the document but instead I get an error message:

EvinceDocument-WARNING **: /usr/lib64/evince/4/backends/libpdfdocument.so: undefined symbol: poppler_annot_markup_set_popup_rectangle


Version-Release number of selected component (if applicable):
Version     : 3.18.0
Release     : 1.fc23

How reproducible:
Open any pdf file.

Steps to Reproduce:
1.
2.
3.

Actual results:
Error message as given above.

Expected results:
PDF file should be displayed.

Additional info:
I reinstlled evince and got the same result.
Comment 1 Frank Ansari 2015-11-21 09:32:40 EST
Reinstallation of evince-libs did also not help.

Installed Packages
Name        : evince-libs
Arch        : x86_64
Epoch       : 0
Version     : 3.18.0
Release     : 1.fc23
Comment 2 Frank Ansari 2015-11-22 04:12:48 EST
I have another system with Fedora 23 and I have tested evince there and it works normally.

So I guess this is not a general bug but something is wrong with my installation.
Comment 3 Frank Ansari 2015-11-22 11:13:25 EST
I have fixed the problem. To avoid that this entry is complete useless for other people I will describe here the issue and how I fixed it.

Since the problem has to do with poppler I checked on both machines for packages with this name:

--> machine where evince is not working:
root@bat ~] # rpm -qa | grep poppler
poppler-glib-0.30.0-3.fc22.x86_64
poppler-utils-0.30.0-3.fc22.x86_64
poppler-0.30.0-3.fc22.x86_64
poppler-data-0.4.7-4.fc23.noarch

--> machine where evince is working
root@intel ~] # rpm -qa | grep poppler
poppler-glib-0.34.0-1.fc23.x86_64
poppler-utils-0.34.0-1.fc23.x86_64
poppler-0.34.0-1.fc23.x86_64
poppler-data-0.4.7-4.fc23.noarch

[fansari@bat backends]$ nm -D /usr/lib64/libpoppler-glib.so.8 | grep poppler_annot_markup
000000000002db10 T poppler_annot_markup_get_date
000000000002dd00 T poppler_annot_markup_get_external_data
000000000002d4b0 T poppler_annot_markup_get_label
000000000002da20 T poppler_annot_markup_get_opacity
000000000002d7f0 T poppler_annot_markup_get_popup_is_open
000000000002d930 T poppler_annot_markup_get_popup_rectangle
000000000002dc60 T poppler_annot_markup_get_reply_to
000000000002dbe0 T poppler_annot_markup_get_subject
000000000002c310 T poppler_annot_markup_get_type
000000000002d660 T poppler_annot_markup_has_popup
0000000000020e60 T poppler_annot_markup_reply_type_get_type
000000000002d530 T poppler_annot_markup_set_label
000000000002da90 T poppler_annot_markup_set_opacity
000000000002d6e0 T poppler_annot_markup_set_popup
000000000002d880 T poppler_annot_markup_set_popup_is_open

[fansari@intel ~]$ nm -D /usr/lib64/libpoppler-glib.so.8 | grep poppler_annot_markup
000000000002dd50 T poppler_annot_markup_get_date
000000000002df40 T poppler_annot_markup_get_external_data
000000000002d630 T poppler_annot_markup_get_label
000000000002dc60 T poppler_annot_markup_get_opacity
000000000002d970 T poppler_annot_markup_get_popup_is_open
000000000002dab0 T poppler_annot_markup_get_popup_rectangle
000000000002dea0 T poppler_annot_markup_get_reply_to
000000000002de20 T poppler_annot_markup_get_subject
000000000002c480 T poppler_annot_markup_get_type
000000000002d7e0 T poppler_annot_markup_has_popup
0000000000021010 T poppler_annot_markup_reply_type_get_type
000000000002d6b0 T poppler_annot_markup_set_label
000000000002dcd0 T poppler_annot_markup_set_opacity
000000000002d860 T poppler_annot_markup_set_popup
000000000002da00 T poppler_annot_markup_set_popup_is_open
000000000002dba0 T poppler_annot_markup_set_popup_rectangle

From this it was clear that on "bat" version 0.30 for libpoppler-glib.so was installed while on "intel" there is version 0.34 (for whatever reason).  And also it is clear checking with "nm -D" that version 0.30 does not contain  symbol "poppler_annot_markup_set_popup_rectangle" and exactly this has caused the problem.

Fixed with

dnf upgrade --best --allowerasing poppler-glib

You can close this bug.

Note You need to log in before you can comment on or make changes to this bug.