Bug 1284187 - blivet.errors.DeviceError: ('cannot replace active format', 'sdb3')
blivet.errors.DeviceError: ('cannot replace active format', 'sdb3')
Status: CLOSED DUPLICATE of bug 1172342
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:09c05733002393e212d08540318...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 11:16 EST by Sergio Belkin
Modified: 2015-11-23 09:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:37:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (786.46 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: anaconda.log (34.10 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: environ (600 bytes, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: journalctl (280.54 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: lsblk_output (3.96 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: nmcli_dev_list (2.00 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: os_info (451 bytes, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: program.log (78.06 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: storage.log (292.32 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details
File: ifcfg.log (7.28 KB, text/plain)
2015-11-21 11:17 EST, Sergio Belkin
no flags Details

  None (edit)
Description Sergio Belkin 2015-11-21 11:16:54 EST
Description of problem:
1. Launch Live Installer
2. Choose Manual Partition
3. Label root partiion
4. Installer stops and cannot continue

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 695, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 740, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 874, in _do_reformat
    device.format = old_format
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 135, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1218, in _save_right_side
    encrypted, selector, fs_type)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2690, in on_update_settings_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/utils.py", line 269, in _run_once_one_arg
    self._func(*args, **kwargs)
blivet.errors.DeviceError: ('cannot replace active format', 'sdb3')

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=(loop)/isolinux/vmlinuz0 iso-scan/filename=/boot/Fedora-Live-KDE-x86_64-23-10.iso root=live:CDLABEL=Fedora-Live-KDE-x86_64-23-10 rootfstype=auto ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: anaconda-gui-23.19.10-1.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Sergio Belkin 2015-11-21 11:17:10 EST
Created attachment 1097472 [details]
File: anaconda-tb
Comment 2 Sergio Belkin 2015-11-21 11:17:12 EST
Created attachment 1097473 [details]
File: anaconda.log
Comment 3 Sergio Belkin 2015-11-21 11:17:14 EST
Created attachment 1097474 [details]
File: environ
Comment 4 Sergio Belkin 2015-11-21 11:17:21 EST
Created attachment 1097475 [details]
File: journalctl
Comment 5 Sergio Belkin 2015-11-21 11:17:22 EST
Created attachment 1097476 [details]
File: lsblk_output
Comment 6 Sergio Belkin 2015-11-21 11:17:24 EST
Created attachment 1097477 [details]
File: nmcli_dev_list
Comment 7 Sergio Belkin 2015-11-21 11:17:26 EST
Created attachment 1097478 [details]
File: os_info
Comment 8 Sergio Belkin 2015-11-21 11:17:29 EST
Created attachment 1097479 [details]
File: program.log
Comment 9 Sergio Belkin 2015-11-21 11:17:35 EST
Created attachment 1097480 [details]
File: storage.log
Comment 10 Sergio Belkin 2015-11-21 11:17:37 EST
Created attachment 1097481 [details]
File: ifcfg.log
Comment 11 Sergio Belkin 2015-11-21 13:52:01 EST
I've found that issue happens when I check format and update the status....
Comment 12 Sergio Belkin 2015-11-21 13:54:43 EST
This issue it does not happen when I boot from LiveUSB

---
Comment 13 Sergio Belkin 2015-11-21 23:23:03 EST
Well,

I think that I've found the solution: the problem was that iso fiile was in the very root partition, because of that, Liveinst refused to unmount it. I've verified moving iso file to another partition and this error went away.

HTH
Comment 14 Sergio Belkin 2015-11-22 12:15:50 EST
Well,

I think that I've found the solution: the problem was that iso fiile was in the very root partition, because of that, Liveinst refused to unmount and format it. I've verified moving iso file to another partition and this error went away.

You may want to close it.
Comment 15 David Shea 2015-11-23 09:37:15 EST

*** This bug has been marked as a duplicate of bug 1172342 ***

Note You need to log in before you can comment on or make changes to this bug.