Bug 1284190 - The file .Xauthority is empty and cinnamon fails to run after login
The file .Xauthority is empty and cinnamon fails to run after login
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-xauth (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-21 13:41 EST by Dimitris
Modified: 2015-11-21 17:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-21 17:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of home user directory (110.26 KB, image/png)
2015-11-21 15:17 EST, leigh scott
no flags Details
.xsession-errors file (2.95 KB, text/plain)
2015-11-21 15:42 EST, Dimitris
no flags Details

  None (edit)
Description Dimitris 2015-11-21 13:41:03 EST
Description of problem:

New installation of Fedora 23 "Cinnamon spin" without any dnf/rpm updates. The system would boot fine and I could login to Cinnamon without problems.

Only issue (probably unrelated to the bug) is that my graphics card is not supported by nouveau and thus Cinnamon runs in software rendering mode.

Then I run "dnf update", everything updates without a problem and I reboot.

I can reach the login screen, I can enter my password and the screen will accept it and try to load Cinnamon, fail and return me back to the login screen.

Via the console (ctrl-alt-f2) I can see the /home/user/.xsession-errors, which says that the file ".Xauthority is empty or none existent". The ".Xauthority" is just a zero-byte empty file.


Version-Release number of selected component (if applicable):

Fedora 23 cinnamon spin (2.8 after update)

How reproducible:

Always

Steps to Reproduce:
1. install Cinnamon spin
2. dnf update
3. try to login

Actual results:

Cinnamon fails to load, returns me back to login screen.

Expected results:

To load Cinnamon.

Additional info:

I enabled rawhide, installed all updates, just to see if this was fixed there, but it made no difference.

Thank you.
Comment 1 leigh scott 2015-11-21 15:17 EST
Created attachment 1097487 [details]
screenshot of home user directory

FTR I don't have a  ~/.Xauthority file and cinnamon works fine here (I use the nvidia  graphics driver here).
Comment 2 Dimitris 2015-11-21 15:42 EST
Created attachment 1097488 [details]
.xsession-errors file
Comment 3 Dimitris 2015-11-21 15:42:57 EST
I've attached my .xsession-errors file, in case its of any help.

I'll go ahead and test with the nvidia binary driver, maybe I'll have better luck.

Thank you.
Comment 4 Dimitris 2015-11-21 17:36:12 EST
I installed the binary drivers from nvidia from http://negativo17.org/nvidia-driver/ and now everything seems to be working fine, I can login without a problem.

(driver 358.16)

Thank you for the suggestion!

Note You need to log in before you can comment on or make changes to this bug.