Bug 1284241 - Drop support for Red Hat Access Plugin [RHOS-8]
Drop support for Red Hat Access Plugin [RHOS-8]
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
x86_64 Linux
high Severity high
: beta
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 05:24 EST by Ido Ovadia
Modified: 2016-04-07 17:13 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.0-8.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:13:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ido Ovadia 2015-11-22 05:24:56 EST
Description of problem:
=======================
Installation of Red Hat Access Plugin is not enforced on OSP-8 Beta 

Version-Release number of selected component:
=============================================
python-django-horizon-8.0.0-4.el7ost.noarch
openstack-dashboard-8.0.0-4.el7ost.noarch
openstack-dashboard-theme-8.0.0-4.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1.Install RHEL-OSP director 8.0 Beta
2.Install overcloud
3.Connect to Horizon

Actual results:
===============
RH theme installed but not Red Hat Access Plugin

Expected results:
================
Red Hat Access Plugin should installed
Comment 2 Jon Schlueter 2015-11-23 14:03:31 EST
Missing BuildRequires from python-django-horizion for OSP 8
Comment 8 Matthias Runge 2015-11-30 14:40:14 EST
That means, we'll have to remove the Requirement on redhat-access-plugin-openstack from python-django-horizon for RHOS-8

Is that right?
Comment 9 Keith Robertson 2015-11-30 15:13:05 EST
Matthias,
This is correct.  If we do not ship redhat-access-plugin-openstack*.rpm and you leave the 'Requires: redhat-access-plugin-openstack' in your spec.  Horizon will fail to install.
Comment 10 Jon Schlueter 2015-11-30 15:35:56 EST
I'll have to also remove the redhat-access-plugin-openstack-7.0.0-0.el7ost package that was included for OSP 8 beta
Comment 14 Amit Ugol 2016-01-25 10:10:43 EST
Package is not there anymore when installing the $fixed_in_version version.
Comment 15 errata-xmlrpc 2016-04-07 17:13:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.