This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1284244 - Eclipse dialog windows do not gain focus
Eclipse dialog windows do not gain focus
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 06:02 EST by Avi Kivity
Modified: 2016-05-01 07:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-01 07:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Kivity 2015-11-22 06:02:48 EST
Description of problem:

Opening a dialog in Eclipse (ctrl-F or ctrl-shift-T) does not transfer the focus to the newly opened dialog.  You have to click the window in order to be able to type into inputs.

Since I did not update my eclipse installation when upgrading to F23, it is either a gtk2 regression or a problem with gtk2/x11/wayland integration.

Version-Release number of selected component (if applicable):
gtk2-2.24.28-2.fc23.x86_64

How reproducible:
Always.


Steps to Reproduce:
1. Start Eclipse
2. Type ctrl+shift+T


Actual results:
Unfocused window opens.

Expected results:
Focused window opens.

Additional info:
Comment 1 Mat Booth 2016-04-30 07:26:21 EDT
We cannot support GTK2 any longer for Eclipse; all development effort is now on GTK3 and Eclipse in Fedora 23 now uses GTK3 by default.

I wonder why your Eclipse did not get updated, did you download it from eclipse.org instead of installing from Fedora repositories?

The latest Eclipse update from the Fedora repositories contains a large number of patches to fix various GTK problems, please try the latest Eclipse from the Fedora repositories to see if the issue is fixed for you there.
Comment 2 Avi Kivity 2016-05-01 07:43:41 EDT
I am using eclipse.org binaries (mostly because I used a self-patched CDT), but:

- the problem went away (I did not even notice when)
- eclipse seems to use gtk3 now (at least it's mentioned in /proc/pid/maps)

Perhaps this got fixed when I updated to Mars.2.

Note You need to log in before you can comment on or make changes to this bug.