Bug 1284245 - [z-stream clone - 3.5.6] Host installation fails or host activation fails with NPE if numaNodeDistance is null [NEEDINFO]
[z-stream clone - 3.5.6] Host installation fails or host activation fails wit...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.5.7
: 3.5.7
Assigned To: Martin Sivák
Artyom
sla
: Triaged, ZStream
Depends On: 1252055
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 06:15 EST by rhev-integ
Modified: 2016-03-31 07:54 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1252055
Environment:
Last Closed: 2016-01-12 15:40:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juwu: needinfo? (msivak)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1569743 None None None Never
oVirt gerrit 45652 master MERGED Fix NPE when processing NUMA info that lacks distances Never
oVirt gerrit 48074 ovirt-engine-3.6 MERGED Fix NPE when processing NUMA info that lacks distances Never
oVirt gerrit 50087 ovirt-engine-3.5 MERGED Improve the handling of empty NUMA distances Never

  None (edit)
Comment 1 Artyom 2015-12-17 10:10:36 EST
Verified on rhevm-3.5.7-0.1.el6ev.noarch
1) Change caps['numaNodeDistance'] = {}
2) restart vdsmd
3) Install host to engine
Engine succeed to deploy host without any errors and numa distance equal to 0 under engine.
Comment 4 errata-xmlrpc 2016-01-12 15:40:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0029.html
Comment 5 Artyom 2016-03-31 07:54:45 EDT
It is some corner case, that happened because hardware error, so I prefer do not add it to QE coverage.

Note You need to log in before you can comment on or make changes to this bug.