Bug 1284257 - Smart State analysis completes successfully (status=ok) but does not show any package information
Summary: Smart State analysis completes successfully (status=ok) but does not show any...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.0
Assignee: Mooli Tayer
QA Contact: Einat Pacifici
URL:
Whiteboard: container
Depends On:
Blocks: 1287773
TreeView+ depends on / blocked
 
Reported: 2015-11-22 12:57 UTC by Einat Pacifici
Modified: 2016-06-29 15:10 UTC (History)
9 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1287773 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:10:16 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
evm.log attached. (10.18 MB, text/plain)
2015-11-22 12:57 UTC, Einat Pacifici
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Einat Pacifici 2015-11-22 12:57:58 UTC
Created attachment 1097531 [details]
evm.log attached.

Description of problem:
When performing smart state analysis on a container image, the task shows as completed OK, but, no information package information is available for the container image. 

Version-Release number of selected component (if applicable):
5.5.0.11

How reproducible:
Always

Steps to Reproduce:
1. containers -> container images
2. select an image
3. click configuration, perform smart state analysis
4. check configuration --> Tasks --> All VM Analysis tasks - status = OK
5. click on containers -> container images
6. Select container image on which you performed smart state analysis


Actual results:
Containers -> Container Image- Configuration - Packages = 0 

Expected results:
Packages should have value greater than 1 and be clickable to show analysis results. 

evm.log attached. 

Additional info:

Comment 3 Federico Simoncelli 2015-11-23 14:19:00 UTC
Einat I don't see anything specific to a smart state analysis task in the log.

Also, I see that the MiqServer configuration is:

[----] I, [2015-11-22T07:47:55.759693 #2739:111398c]  INFO -- : MiqServer: local=Y, master=Y, status= started, id=00001, pid=02739, guid=6b51f1ac-8e2a-11e5-b4d7-005056b62555, name=EVM, zone=default, hostname=10-16-7-187.rhq.lab.eng.bos.redhat.com, ipaddress=10.16.7.187, version=5.5.0.11-rc1, build=20151117182049_653c0d4, active roles=automate:database_operations:database_owner:ems_inventory:ems_operations:event:reporting:scheduler:smartstate:user_interface:web_services


which is lacking the "smartproxy" role (in this case it's common to see the task to go to timeout, but it should be properly reported to the UI).

Comment 4 Mooli Tayer 2015-11-26 08:58:35 UTC
submitted upstream: https://github.com/ManageIQ/manageiq/pull/5616

All error types should now be reported by containers smart state job.

Comment 7 Lucy Bopf 2016-05-17 04:44:41 UTC
It appears that this bug should no longer be documented as a known issue (and the requires_doc_text flag has been set to '-'). Removing doc text as well.

Comment 9 errata-xmlrpc 2016-06-29 15:10:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.