Bug 1284257 - Smart State analysis completes successfully (status=ok) but does not show any package information
Smart State analysis completes successfully (status=ok) but does not show any...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Mooli Tayer
Einat Pacifici
container
:
Depends On:
Blocks: 1287773
  Show dependency treegraph
 
Reported: 2015-11-22 07:57 EST by Einat Pacifici
Modified: 2016-06-29 11:10 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1287773 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:10:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evm.log attached. (10.18 MB, text/plain)
2015-11-22 07:57 EST, Einat Pacifici
no flags Details

  None (edit)
Description Einat Pacifici 2015-11-22 07:57:58 EST
Created attachment 1097531 [details]
evm.log attached.

Description of problem:
When performing smart state analysis on a container image, the task shows as completed OK, but, no information package information is available for the container image. 

Version-Release number of selected component (if applicable):
5.5.0.11

How reproducible:
Always

Steps to Reproduce:
1. containers -> container images
2. select an image
3. click configuration, perform smart state analysis
4. check configuration --> Tasks --> All VM Analysis tasks - status = OK
5. click on containers -> container images
6. Select container image on which you performed smart state analysis


Actual results:
Containers -> Container Image- Configuration - Packages = 0 

Expected results:
Packages should have value greater than 1 and be clickable to show analysis results. 

evm.log attached. 

Additional info:
Comment 3 Federico Simoncelli 2015-11-23 09:19:00 EST
Einat I don't see anything specific to a smart state analysis task in the log.

Also, I see that the MiqServer configuration is:

[----] I, [2015-11-22T07:47:55.759693 #2739:111398c]  INFO -- : MiqServer: local=Y, master=Y, status= started, id=00001, pid=02739, guid=6b51f1ac-8e2a-11e5-b4d7-005056b62555, name=EVM, zone=default, hostname=10-16-7-187.rhq.lab.eng.bos.redhat.com, ipaddress=10.16.7.187, version=5.5.0.11-rc1, build=20151117182049_653c0d4, active roles=automate:database_operations:database_owner:ems_inventory:ems_operations:event:reporting:scheduler:smartstate:user_interface:web_services


which is lacking the "smartproxy" role (in this case it's common to see the task to go to timeout, but it should be properly reported to the UI).
Comment 4 Mooli Tayer 2015-11-26 03:58:35 EST
submitted upstream: https://github.com/ManageIQ/manageiq/pull/5616

All error types should now be reported by containers smart state job.
Comment 7 Lucy Bopf 2016-05-17 00:44:41 EDT
It appears that this bug should no longer be documented as a known issue (and the requires_doc_text flag has been set to '-'). Removing doc text as well.
Comment 9 errata-xmlrpc 2016-06-29 11:10:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.