Bug 1284259 - Machine UUID format mismatch
Machine UUID format mismatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: seabios (Show other bugs)
24
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 08:09 EST by poma
Modified: 2016-03-26 14:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: seabios-1.9.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:02:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SeaBIOS 1.9.0 (3.41 KB, image/png)
2015-11-22 08:09 EST, poma
no flags Details
Machine UUID format match - SeaBIOS 1.9 (860 bytes, patch)
2016-01-12 08:26 EST, poma
no flags Details | Diff
Machine UUID format match - SeaBIOS 1.8 (860 bytes, patch)
2016-01-12 08:26 EST, poma
no flags Details | Diff
SeaBIOS 1.9 UUID OK (4.03 KB, image/png)
2016-01-12 08:27 EST, poma
no flags Details

  None (edit)
Description poma 2015-11-22 08:09:23 EST
Created attachment 1097533 [details]
SeaBIOS 1.9.0

Description of problem:
Machine UUID format mismatch compared with the output of other cool tools

Version-Release number of selected component (if applicable):
seabios-1.9.0-1.fc24.noarch

How reproducible:
101%

Steps to Reproduce:
1. Run qemu-system-x86_64 \
       -boot menu=on -uuid 01234567-89AB-CDEF-EDCB-A98765432101 ...

Actual results:
Machine UUID format -mismatch-

Expected results:
Machine UUID format -match-

Additional info:
SeaBIOS
Machine UUID 67452301-ab89-efcd-edcb-a98765432101

(qemu) info uuid
01234567-89ab-cdef-edcb-a98765432101

# virsh dominfo Rawhide | grep UUID
UUID:           01234567-89ab-cdef-edcb-a98765432101

# dmidecode -s system-uuid
01234567-89AB-CDEF-EDCB-A98765432101


Ref.
smbios uuid mismatched
https://bugzilla.redhat.com/show_bug.cgi?id=1152922

SMBIOS: Build aggregate smbios tables and entry point
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=c97294e

smbios: Encode UUID according to SMBIOS specification
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=caad057
Comment 1 Cole Robinson 2015-11-24 12:01:58 EST
yeah seems like that the newer smbios format is the issue, seabios.git doesn't show any signs of handling it. I mailed the seabios list about it
Comment 2 poma 2016-01-07 05:50:22 EST
Is anyone working on a solution?
Comment 3 Cole Robinson 2016-01-07 10:37:22 EST
I don't think so. For reference here was the thread:

http://www.seabios.org/pipermail/seabios/2015-November/010028.html
Comment 4 poma 2016-01-12 08:26 EST
Created attachment 1113947 [details]
Machine UUID format match - SeaBIOS 1.9
Comment 5 poma 2016-01-12 08:26 EST
Created attachment 1113948 [details]
Machine UUID format match - SeaBIOS 1.8
Comment 6 poma 2016-01-12 08:27 EST
Created attachment 1113950 [details]
SeaBIOS 1.9 UUID OK


diff --git a/src/fw/biostables.c b/src/fw/biostables.c
index cb74396..52d7730 100644
--- a/src/fw/biostables.c
+++ b/src/fw/biostables.c
@@ -312,9 +312,9 @@ display_uuid(void)
                    "-%02x%02x"
                    "-%02x%02x"
                    "-%02x%02x%02x%02x%02x%02x\n"
-                   , uuid[ 0], uuid[ 1], uuid[ 2], uuid[ 3]
-                   , uuid[ 4], uuid[ 5]
-                   , uuid[ 6], uuid[ 7]
+                   , uuid[ 3], uuid[ 2], uuid[ 1], uuid[ 0]
+                   , uuid[ 5], uuid[ 4]
+                   , uuid[ 7], uuid[ 6]
                    , uuid[ 8], uuid[ 9]
                    , uuid[10], uuid[11], uuid[12], uuid[13], uuid[14], uuid[15]);
             return;
Comment 7 Cole Robinson 2016-01-12 14:34:31 EST
We can't unconditionally change it, the format is dependent on the smbios version. I sent a patch:

http://www.seabios.org/pipermail/seabios/2016-January/010311.html
Comment 8 poma 2016-01-15 14:27:58 EST
(In reply to poma from comment #6)
> Created attachment 1113950 [details]
> SeaBIOS 1.9 UUID OK
> 
> 
> diff --git a/src/fw/biostables.c b/src/fw/biostables.c
> index cb74396..52d7730 100644
> --- a/src/fw/biostables.c
> +++ b/src/fw/biostables.c
> @@ -312,9 +312,9 @@ display_uuid(void)
>                     "-%02x%02x"
>                     "-%02x%02x"
>                     "-%02x%02x%02x%02x%02x%02x\n"
> -                   , uuid[ 0], uuid[ 1], uuid[ 2], uuid[ 3]
> -                   , uuid[ 4], uuid[ 5]
> -                   , uuid[ 6], uuid[ 7]
> +                   , uuid[ 3], uuid[ 2], uuid[ 1], uuid[ 0]
> +                   , uuid[ 5], uuid[ 4]
> +                   , uuid[ 7], uuid[ 6]
>                     , uuid[ 8], uuid[ 9]
>                     , uuid[10], uuid[11], uuid[12], uuid[13], uuid[14],
> uuid[15]);
>              return;


Reported-by: poma <poma@gmail.com>
Tested-by: poma <poma@gmail.com>
Suggested-by: poma <poma@gmail.com>
Comment 9 poma 2016-01-15 14:28:32 EST
"biostables: Support SMBIOS 2.6+ UUID format"
http://code.coreboot.org/p/seabios/source/commit/2e11d58
Comment 10 poma 2016-01-19 15:10:40 EST
(In reply to poma from comment #9)
> "biostables: Support SMBIOS 2.6+ UUID format"
> http://code.coreboot.org/p/seabios/source/commit/2e11d58

Signed-off-by: Cole Robinson <crobinso@redhat.com>
Comment 11 poma 2016-01-19 15:16:34 EST
13) Using Reported-by:, Tested-by:, Reviewed-by:, Suggested-by: and Fixes:

~~~

"The Reported-by tag gives credit to people who find bugs and report them and it
hopefully inspires them to help us again in the future."

= hopefully inspires them to help us again in the future =

~~~

"A Tested-by: tag indicates that the patch has been successfully tested (in
some environment) by the person named.  This tag informs maintainers that
some testing has been performed, provides a means to locate testers for
future patches, and ensures credit for the testers."

= informs maintainers that some testing has been performed =

~~~

"A Suggested-by: tag indicates that the patch idea is suggested by the person
named and ensures credit to the person for the idea. Please note that this
tag should not be added without the reporter's permission, especially if the
idea was not posted in a public forum. That said, if we diligently credit our
idea reporters, they will, hopefully, be inspired to help us again in the
future."

= credit our idea reporters, they will, hopefully, be inspired to help us again in the future =

~~~

Ref.
https://www.kernel.org/doc/Documentation/SubmittingPatches
Comment 12 poma 2016-01-19 15:18:10 EST
Thank you very much for your support!
Comment 13 Cole Robinson 2016-01-19 16:37:31 EST
I apologize for not adding a Reported-by tag, it wasn't deliberate, I just didn't think of it.

I'm not going to add Tested-by tags on someone else's behalf. If you want to report your test results, I suggest responding to the actual mail thread in the future. Aside from that you never indicated you actually tested the patch that went upstream

Suggested-by is partly applicable here since you helpfully identified the original seabios bug, but you didn't suggest the actual committed solution which takes more elements into account. So that's a toss up

There's also the problem that you don't report your real name. Probably doesn't matter for these extra meta tags, but at least qemu rejects aliases for Signed-off-by: . Something to consider

If you want to ensure full proper credit in the future, I suggest engaging directly with upstream since you obviously have the capabilities to write and and test patches. That said I will try to be more thoughtful when similar situations arise in the future and give proper credit

Setting to POST (meaning there's a patch available upstream)
Comment 14 poma 2016-01-21 07:25:44 EST
After a whole discussion upstream, guess what has been done, nooooothiiiiing.

Therefore, because the original patch arises from here,
simple "thanks" will do, man.
Comment 15 Cole Robinson 2016-01-21 10:08:16 EST
Thank you for filing a helpful bug report and for pushing this along
Comment 16 Cole Robinson 2016-03-17 11:07:43 EDT
Pushing 1.9.1 to f24, so reassigning this bug. F23 and earlier aren't on seabios 1.9 series
Comment 17 Fedora Update System 2016-03-17 11:58:40 EDT
seabios-1.9.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-30f49486cc
Comment 18 Fedora Update System 2016-03-18 10:56:38 EDT
seabios-1.9.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-30f49486cc
Comment 19 Fedora Update System 2016-03-26 14:02:03 EDT
seabios-1.9.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.