Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 128427 - kernel 2.6.6 1.5 times slower than 2.4.22 in cpu intensive programs
kernel 2.6.6 1.5 times slower than 2.4.22 in cpu intensive programs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 15:48 EDT by Fernando Aristides Castro
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 23:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Aristides Castro 2004-07-22 15:48:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
A cpu intensive application running on fedora 2 using kernel 2.6.6 is
1.5 times slower than on fedora 1 using kernel 2.4.22. The application
is a computational fluid dynamics fortran code compiled using either
ifort or g77. The machine is a centrino 1.4 GHz (thinkpad t41
2373-2fg) with 768MB RAM. No swap was observed during tests on both
installations.

Version-Release number of selected component (if applicable):
kernel 2.6.6

How reproducible:
Always

Steps to Reproduce:
1.compile
2.execute
3.get time
    

Expected Results:   

Additional info:

I've saw some posts about 2.6 beeing slower than 2.4 but not 1.5 times
slower.
Comment 1 Warren Togami 2004-07-22 21:17:07 EDT
We are unlikely to be able to investigate why you see this behavior
unless you can post a freely distributable test suite that exhibits
this problem.  Only then would developers be able to profile it and
see what the cause is.
Comment 2 Fernando Aristides Castro 2004-07-23 09:33:32 EDT
After some tests I found that if I run the program outside the X
environment, using init 3 on the startup, there is no significant
difference between kernels. So, my complain is not correct and this
seems more a question about fedora 2/fedora 1 and X environment.


What makes me believe that was a kernel problem was the fact that a
2.4.22 kernel that I force into fedora 2 enabled the code running 1.5
times faster, recovering the performance that I use to have in fedora
1. 

For my this bug is closed

Thanks
Comment 3 Dave Jones 2004-11-27 15:20:19 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?

Note You need to log in before you can comment on or make changes to this bug.