Bug 1284285 - java not required
java not required
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
21
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 16:48 EST by Richard Jasmin
Modified: 2015-12-01 06:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 06:41:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2015-11-22 16:48:28 EST
Description of problem:
App complains when Java disabled(which apparently takes forever to load) within the application but for most often used tasks, java is not required, including to preload the application suite.

App complains anyways.

Version-Release number of selected component (if applicable):
21+

How reproducible:
once triggered, always

Steps to Reproduce:
"
Halt Java

The JRE in OpenOffice.org is the main culprit for the slow startups. You don't need the JRE to run in a day to day environment, so you can safely disable it, and in the event you do need the JRE you can quickly re-enable it. Simply head to Tools > Options > LiberOffice > Advanced. To disable the JRE simply uncheck the box next to Use A Java Runtime Environment.
"

Actual results:
Please enable Java......do you want to enable Java?

Expected results:
why are you complaining?
Comment 1 Stephan Bergmann 2015-11-23 03:21:05 EST
I do not understand your "Steps to Reproduce" and "Actual results."  You are presumably quoting text from somewhere, but it is unclear to me what and from where.

If LibreOffice complains during start up that Java is disabled, that most likely means that you have an extension installed that requires Java, and that due to how that extension is implemented it already wants to execute some of its Java code during start up.  Look into "Tools - Extensions..." and see if disabling specific extensions makes the problem go away.

Note You need to log in before you can comment on or make changes to this bug.