Bug 1284290 - rpm file triggers syntax does not accept --priority
rpm file triggers syntax does not accept --priority
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-22 17:54 EST by Zbigniew Jędrzejewski-Szmek
Modified: 2015-11-25 04:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 04:48:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-11-22 17:54:36 EST
Description of problem:
http://www.rpm.org/wiki/FileTriggers says "FILE_TRIGGER_OPTIONS are the same as options for other rpm scriptlets except for option -P/--priority". "-P XXX" works, but neither --priority=XXX nor --priority XXX do. Using -P is a good enough solution, but anyone trying this is likely to waste time trying to figure out the syntax.

error: line 153: Dependency tokens must begin with alpha-numeric, '_' or '/'

Version-Release number of selected component (if applicable):
rpm-4.13.0-0.rc1.6.fc23.x86_64
Comment 1 Ľuboš Kardoš 2015-11-25 04:48:12 EST
The long option --priority doens't work because of the way how the parser parses trigger definitions, everything after "--" is considered to be a trigger target. I removed mention of option "--priority" from http://www.rpm.org/wiki/FileTriggers in order not to confuse anybody.

Note You need to log in before you can comment on or make changes to this bug.