Bug 1284350 - The position of "Beta" keyword is not suitable in "/etc/redhat-release"
The position of "Beta" keyword is not suitable in "/etc/redhat-release"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.2
: 3.6.1
Assigned To: Ryan Barry
cshao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 00:26 EST by cshao
Modified: 2016-02-10 14:17 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 10:15:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL VS RHEV-H (24.85 KB, image/png)
2015-11-25 22:47 EST, cshao
no flags Details

  None (edit)
Description cshao 2015-11-23 00:26:15 EST
Description of problem:
The position of word "Beta" is not suitable in plymouth.

It show as: 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)

It should be:
Red Hat Enterprise Virtualization Hypervisor release 7.2 (Beta) (20151112.1.el7ev)


Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install RHEV-H 7.2.
2. Focus on plymouth or run below cmd in shell.
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)


Actual results:
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)


Expected results:
Red Hat Enterprise Virtualization Hypervisor release 7.2 (Beta) (20151112.1.el7ev)

Additional info:
Comment 1 Fabian Deutsch 2015-11-25 07:06:34 EST
What is the reason for requesting this change?
Why is the current position not good?
Comment 2 cshao 2015-11-25 22:46:58 EST
In RHEL, it show as 
Red Hat Enterprise Linux Server release 7.2 Beta

In RHEV-H:
Plymouth shown correctly.
But in /etc/redhat-release, it shouw as:
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)

So I suggest it should be:
Red Hat Enterprise Virtualization Hypervisor release 7.2 (Beta) (20151112.1.el7ev)

Please see the attachment "RHEL VS RHEV-H" for more details.
Comment 3 cshao 2015-11-25 22:47 EST
Created attachment 1099092 [details]
RHEL VS RHEV-H
Comment 4 Fabian Deutsch 2015-12-09 10:12:49 EST
Getting the positioning of the Beta keyword right in plymouth and in the os-release is not a one shot thing.
Comment 6 Fabian Deutsch 2015-12-17 10:15:41 EST
We have seen - again - that the re-positioning of the "beta" string can lead to broken builds. The benefit of this fix does not justify the risk. Thus closing this bug.

Note You need to log in before you can comment on or make changes to this bug.