Bug 1284381 - Configuration node global/system_id_source not found
Configuration node global/system_id_source not found
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
:
: 1292204 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 03:40 EST by Jan Synacek
Modified: 2016-01-21 02:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 04:50:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug output (2.18 MB, text/plain)
2015-11-23 04:15 EST, Jan Synacek
no flags Details

  None (edit)
Description Jan Synacek 2015-11-23 03:40:15 EST
Description of problem:
I'm getting "Configuration node global/system_id_source not found" message when recreating dracut.


Version-Release number of selected component (if applicable):
dracut-043-60.git20150811.fc23.x86_64
systemd-222-8.fc23.x86_64


Steps to Reproduce:
1. sudo dracut -f


Actual results:
Configuration node global/system_id_source not found.


Expected results:
No message.
Comment 1 Jan Synacek 2015-11-23 04:01:02 EST
$sudo dracut --kver 4.2.5-300.fc23.x86_64 --force -v
Executing: /usr/bin/dracut --kver 4.2.5-300.fc23.x86_64 --force -v
*** Including module: dm ***
Skipping udev rule: 64-device-mapper.rules
Skipping udev rule: 60-persistent-storage-dm.rules
Skipping udev rule: 55-dm.rules
*** Including module: lvm ***
  Configuration node global/system_id_source not found
Skipping udev rule: 64-device-mapper.rules
Skipping udev rule: 56-lvm.rules
Skipping udev rule: 60-persistent-storage-lvm.rules
*** Including module: rootfs-block ***
*** Including module: fs-lib ***
*** Including modules done ***
*** Installing kernel module dependencies and firmware ***
*** Installing kernel module dependencies and firmware done ***
*** Resolving executable dependencies ***
*** Resolving executable dependencies done***
*** Hardlinking files ***
*** Hardlinking files done ***
*** Stripping files ***
*** Stripping files done ***
*** Generating early-microcode cpio image ***
*** Constructing GenuineIntel.bin ****
*** Store current command line parameters ***
Stored kernel commandline:
No dracut internal kernel commandline stored in initrd
*** Creating image file '/boot/initramfs-4.2.5-300.fc23.x86_64.img' ***
*** Creating initrd image file '/boot/initramfs-4.2.5-300.fc23.x86_64.img' done ***

Looks like dracut doesn't like the lvm module added in my configuration.
Comment 2 Jan Synacek 2015-11-23 04:06:36 EST
$ cat /etc/dracut.conf.d/99-jsynacek.conf 
dracutmodules+="lvm"
install_items+="resize2fs"

Btw, the initrd created like this has only about 7MB, whereas the original had about 18MB. The new one makes the kernel panic right at the start.
Comment 3 Jan Synacek 2015-11-23 04:15 EST
Created attachment 1097599 [details]
debug output
Comment 4 Harald Hoyer 2015-11-24 04:50:07 EST
- dracutmodules+="lvm"
+ add_dracutmodules+=" lvm "
Comment 5 Daniel Miranda 2015-12-29 06:25:33 EST
I have no extra dracut configuration of any kind and I still see the warning. It seems it's because there isn't really a systemd id source configured on the default lvm.conf. Wouldn't it make sense to set it to 'machineid' by default?
Comment 6 Jan Synacek 2016-01-04 03:32:17 EST
Daniel, check your /etc/lvm/lvm.conf. I have found out that mine was *very* old and the latest one was kept as lvm.conf.new during updates. The new configuration has the correct node.
Comment 7 Ľuboš Kardoš 2016-01-21 02:06:28 EST
*** Bug 1292204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.