Bug 1284394 - boinc user doesn't have ownership over /var/lib/boinc
boinc user doesn't have ownership over /var/lib/boinc
Status: CLOSED DUPLICATE of bug 1278881
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Laurence Field
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 03:51 EST by Kees de Jong
Modified: 2015-12-04 07:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 07:50:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kees de Jong 2015-11-23 03:51:20 EST
How reproducible:
When Boinc is installed, the folder /var/lib/boinc doesn't get populated with the necessary files. This is because the boinc-client can't access the folder.


Steps to Reproduce:
1. Start the boinc-client with systemctl
2. Open the Boinc Manager in GNOME
3. Nothing happens, you can't select any projects, this is because boinc-client can't access the folder.

Expected results:
When the Boinc Manager is started, the user should be able to add projects.


Additional info:
The operating user should also be in the boinc group. So it would be a good idea to at least set the right ownership of /var/lib/boinc and state in the man page that the operating user should be added to this boinc group.

[root@defiant ~]# ll -d /var/lib/boinc
drwxrwxr-x. 5 boinc boinc 4096 Nov 23 09:46 /var/lib/boinc

[root@defiant ~]# id keesj
uid=1000(keesj) gid=1000(keesj) groups=1000(keesj),978(boinc)
Comment 1 Germano Massullo 2015-12-04 07:50:22 EST

*** This bug has been marked as a duplicate of bug 1278881 ***

Note You need to log in before you can comment on or make changes to this bug.