Bug 1284398 - [userinterface_public_501]Deletion buttons must be clicked twice to work on ipad/iphone
[userinterface_public_501]Deletion buttons must be clicked twice to work on i...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 04:02 EST by Yanping Zhang
Modified: 2016-05-12 13:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanping Zhang 2015-11-23 04:02:57 EST
Description of problem:
When try to delete resource from web console on ipad/iphone, the "Delete" info won't show up by hovering on the button, users have to click on the button to show the "Delete" info, and click again to make the interactive dialogue display.

Version-Release number of selected component (if applicable):
$ openshift version
openshift v1.1-123-g60e7a07
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always

Steps to Reproduce:
1.Create app in project
2.Try to delete resources from web console on ipad/iphone
3.

Actual results:
2.Deletion buttons on all the pages have to be clicked twice, then user can choose to delete the resource or not.

Expected results:
1.Should only be clicked once then user can make a choice.

Additional info:
Comment 1 Samuel Padgett 2015-12-01 12:05:56 EST
This is happening because of the tooltip that appears on hover. Mobile Safari will treat the first touch event as a hover and the second as a click.

I could try to remove the tooltip only on iOS, but I'm not sure it's the right approach. Do we need the tooltip at all? The trash icon seems pretty obvious (with an sr-only label), and there's a dialog that prompts before we delete anything.
Comment 2 Samuel Padgett 2015-12-01 14:37:04 EST
https://github.com/openshift/origin/pull/6152
Comment 3 Yanping Zhang 2015-12-03 00:49:07 EST
The pull 6152 is not merged yet, will check the issue after the pull is merged.
Comment 4 Yanping Zhang 2015-12-04 03:39:51 EST
Tested on devenv-rhel7_2871 against ipad2/iphone6s. 
# openshift version
openshift v1.1-330-g693be19
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

Now user can choose to delete resources after click once on the button.

Note You need to log in before you can comment on or make changes to this bug.