Bug 128442 - autofs hangs on ASUS P4P800E-Deluxe motherboards
autofs hangs on ASUS P4P800E-Deluxe motherboards
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-22 17:58 EDT by Ed Friedman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 16:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2004-07-22 17:58:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
On the ASUS P4P800-E Deluxe motherboards, autofs hangs occasionally. 
It always hangs at shutdown, and while running, autofs partitions
occasionally hang until you reboot. On one occasion a directly mounted
partition hung for over a day before I spotted it.  Again, this
problem was fixed by rebooting.

Version-Release number of selected component (if applicable):
4.1.2-2

How reproducible:
Always

Steps to Reproduce:
1.Turn on /net option in /etc/auto.master
2.Have links that point to /net/machinename/partitionname
3.Periodically access those links via ls or cd
    

Actual Results:  The ls or cd command would hang until the machine was
rebooted.

Expected Results:  The ls command should have listed the directory and
the cd command should have taken you to that directory.

Additional info:

I have only seen this on two such motherboards.  It is reproducible on
those machines, and both machines have switched to running Fedora Core
1 which has totally fixed these problems.
Comment 1 Barry K. Nathan 2004-07-26 09:22:44 EDT
Which kernel(s) caused this under Fedora Core 2?
Comment 2 Ed Friedman 2004-07-26 11:43:30 EDT
This occurred both in the original kernel (2.6.5-1.358) and in
2.6.6-1.435.2.3.

Also, I should clarify that the directly mounted partition that I
mentioned as being hung was a directly mounted NFS partition.
Comment 3 Jeffrey Moyer 2004-07-30 07:48:17 EDT
Is there any automount information in the system logs?  Please include
it if so.

If not, please add --debug to your auto.master entries for the hanging
mount points, and attach the debug output here.

Thanks!
Comment 4 Ed Friedman 2004-07-30 13:09:58 EDT
The following is from an ASUS TR-DLS motherboard running
kernel-smp-2.6.6-1.435.2.3 (the other machines were also running smp
kernels - I don't recall if I tried it without smp):

Jul 29 12:22:40 florence automount[4328]: >> /usr/sbin/showmount:
can't get address for galton/ga
Jul 29 12:22:40 florence automount[4328]: lookup(program): lookup for
galton/ga
failed
Jul 29 12:22:40 florence automount[4328]: failed to mount /net/galton/ga
Jul 29 12:25:10 florence kernel: nfs_statfs: statfs error = 512
Jul 29 12:25:34 florence automount[4315]: >> mount: mount point
/net/galton/ga does not exist
Jul 29 12:25:34 florence automount[4315]: mount(nfs): nfs: mount
failure galton:/ga on /net/galton/ga
Jul 29 12:25:34 florence automount[4315]: failed to mount /net/galton
Comment 5 Ed Friedman 2004-08-27 15:38:58 EDT
I just checked the new kernel-smp-2.6.8-1.521 and it fixes the
automount problem.  (It causes a segmentation fault whenever I run
netscape 7.1 now, but there's always mozilla:).
Comment 6 Jeffrey Moyer 2004-08-31 18:18:06 EDT
Are things still operating okay?  Can I change the state of the bug?
Comment 7 Ed Friedman 2004-09-02 12:33:40 EDT
Oops - the problem came back after a couple of days.  I tried adding
--debug to auto.master, but go no useful information.  I did notice
that /net/machinename/ would only list a few (instead of all) of the
exported partitions with autofs turned on when this problem occurred.
 It is possible that it is all a problem with the ethernet driver
(sk98lin), although everything works just fine under Fedora 1.  Also,
direct NFS mounts are definitely being disconnected, not just automounts.
Comment 8 Ed Friedman 2004-09-03 18:11:26 EDT
I just tried Fedora 3 Test 1, and the same problem exists.  The
--debug flag gave me the following info on /var/log/messages:

Sep  2 17:07:13 congolo automount[4647]: mount(nfs): nfs: mount
failure tachyon:/tc on /net/tachyon/tc
Sep  2 17:07:13 congolo automount[4647]: >> nfs bindresvport: Address
already in use
Sep  2 17:07:13 congolo automount[4647]: mount(nfs): nfs: mount
failure tachyon:/zc on /net/tachyon/zc
Sep  2 17:07:13 congolo automount[4638]: attempting to mount entry
/net/tachyon/ac
Sep  2 17:07:13 congolo automount[4669]: >> /usr/sbin/showmount: can't
get address for tachyon/ac
Sep  2 17:07:13 congolo automount[4669]: lookup(program): lookup for
tachyon/ac
failed
Sep  2 17:07:13 congolo automount[4669]: failed to mount /net/tachyon/ac
Sep  2 17:07:13 congolo automount[4669]: rm_unwanted: /net/tachyon/ac
Comment 9 Jeffrey Moyer 2004-09-03 18:19:03 EDT
I recently fixed a socket leak in the autofs package.  Could you try
autofs-4.1.3-16 from my people page:
  http://people.redhat.com/jmoyer/

thanks!
Comment 10 Ed Friedman 2004-09-15 14:13:54 EDT
autofs-4.1.3-16 seems to be working perfectly for the last few days
(even without putting in the kernel patch) for Fedora 3 Test 1.

However, autofs-4.1.3-4 does not fix the problem for Fedora 2.  Any
chance of getting a fixed version for Fedora 2?
Comment 11 Jeffrey Moyer 2005-04-05 16:07:45 EDT
Fedora 2 is not getting updates anymore.  I'm going to close this bug.  Please
re-open if you are experiencing difficulties.  I will note that many changes
have since gone into autofs, and I think you'll find the latest rawhide to be
pretty stable.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.