Bug 1284480 - [ppc64] VM crashes on hotplug NIC
[ppc64] VM crashes on hotplug NIC
Status: CLOSED DUPLICATE of bug 1270717
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
ppc64le Linux
unspecified Severity urgent
: rc
: ---
Assigned To: David Gibson
Virtualization Bugs
Depends On:
Blocks: RHV4.1PPC RHEV4.0PPC
  Show dependency treegraph
Reported: 2015-11-23 07:55 EST by GenadiC
Modified: 2016-07-25 10:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-12-04 03:22:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
engine, libvirt, vdsm, qemu logs (7.70 MB, application/zip)
2015-11-23 07:55 EST, GenadiC
no flags Details

  None (edit)
Description GenadiC 2015-11-23 07:55:02 EST
Created attachment 1097641 [details]
engine, libvirt, vdsm, qemu logs

Description of problem:
When you try to plug/unplug NIC on VM or add additional vNIC the VM goes down as a connection to qemu process is lost

Version-Release number of selected component (if applicable):

How reproducible:
Takes a bit of time, but if you plug/unplug existing vNIC or add, remove vNIC from VM the VM goes down

Steps to Reproduce:
1. Add vNIC to VM
2. Unplug existing vNIC
3. Plug vNIC back
4 Go over above steps several times

Actual results:
VM goes down with error message: Lost connection with qemu process

Expected results:
VM should be up and running

Additional info:
Comment 2 Michal Skrivanek 2015-11-23 09:49:56 EST
what is the guest OS? Is it running?
Comment 3 Michal Skrivanek 2015-11-23 10:00:56 EST
I didn't see guest side logs but the scenario matches bug 1270717
Comment 4 Karen Noel 2015-11-23 19:21:36 EST
(In reply to Michal Skrivanek from comment #3)
> I didn't see guest side logs but the scenario matches bug 1270717

The RHEL 7.2.z bugzilla is: bug 1279793

Fixed in: kernel-3.10.0-327.2.1.el7
Comment 5 GenadiC 2015-11-24 03:28:21 EST
VM is RHEL 7.2 and VM is up when doing actions of add NIC, plug/unplug.
This is the bz - when you do those action VM crashes and goes down
Comment 6 David Gibson 2015-11-24 18:15:06 EST
This is almost certainly the same as bug 1270717 / bug 1279793.  Please retry with kernel-3.10.0-327.2.1.el7.  Note that this bug can cause crashes in either host or guest, so you'll want to update the kernel in both.
Comment 7 Ilanit Stein 2015-11-26 14:54:42 EST
This bug do not happen with these new versions on host:

kernel 3.10.0-327.2.1.el7.ppc64le (also on guest)
and libvirt-1.2.17-13.el7_2.2.ppc64le
Comment 8 Michal Skrivanek 2015-12-04 03:22:25 EST
thanks for confirmation, I'm closing it then as a duplicate of 1270717

*** This bug has been marked as a duplicate of bug 1270717 ***

Note You need to log in before you can comment on or make changes to this bug.