Bug 1284493 - Delete instance should veify instance is deleted before returning [NEEDINFO]
Delete instance should veify instance is deleted before returning
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
nlevinki
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 08:33 EST by yfried
Modified: 2015-11-25 12:58 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 12:05:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
yfried: needinfo? (eglynn)


Attachments (Terms of Use)

  None (edit)
Description yfried 2015-11-23 08:33:41 EST
Description of problem:
Nova operations are async and return before they are done. This is problematic during cleanup scripts and automation (Tempest, Khaleesi, etc...) where VM deletion returns before the VM is deleted and subsequent resource deletions will fail because VM is still alive on the system

As a result each script needs to implement a waiter to handle nova resources

Please add a flag that will force nova operations to become sync like other clients and return only when operation is actually done.

How reproducible:
$ nova delete <vm> && nova show <vm>

Actual results:
VM is shown in "deleting" state

Expected results:
404 error - VM doesn't exist.
Comment 2 Eoghan Glynn 2015-11-24 12:05:30 EST
This aynchrony is intended behavior in the nova API and realistically-speaking will not be changed upstream.
Comment 3 yfried 2015-11-25 12:58:08 EST
Can't we ADD a sync mode where we wait for actions to complete?

Note You need to log in before you can comment on or make changes to this bug.