Bug 1284498 - katello-installer fails when there is the http_proxy variable set
katello-installer fails when there is the http_proxy variable set
Status: CLOSED DUPLICATE of bug 1255247
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.4
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Chris Roberts
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 08:41 EST by Marcel Gazdík
Modified: 2016-06-24 05:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-24 05:47:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Gazdík 2015-11-23 08:41:23 EST
Description of problem:
  When you setup the http_proxy + https_proxy and run the katello installer it fails. To be able to proceed, you have to 
  a) unset the http(s)_proxy variables
  b) add 127.0.0.1, localhost, $(hostname -f), all_other_satellite_IPs to the no_proxy variable.

However, that is not listed in the documentation. The culprit is the wget command when it is checking candlepin availability. My recommended solution is
to modify the documentation (user guide, BZ: 1282739). Or add the --no-proxy parameter, when the candlepin is running locally. 


Version-Release number of selected component (if applicable):
6.1.z

How reproducible:
Setup http(s)_proxy variables before you run katello-install 


Steps to Reproduce:
1. export http_proxy="http://some_proxy_ip:port"
   export https_proxy=$http_proxy
   in /etc/profile


2. re-login and run katello-install


Actual results:
/usr/bin/wget --timeout=30 --tries=40 --wait=20 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 8 instead of one of [0]
 /Stage[main]/Candlepin::Service/Exec[cpinit]/returns: change from notrun to 0 failed: /usr/bin/wget --timeout=30 --tries=40 --wait=20 --retry-connrefused -qO- http://localhost:8080/candlepin/admin/init >/var/log/candlepin/cpinit.log 2>&1 && touch /var/lib/candlepin/cpinit_done returned 8 instead of one of [0]


Setting the no_proxy variable to "localhost, 127.0.0.1, $(hostname -f), all_other_satellite_IPs"

will result into:
 /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[sat_fqdn]: Could not evaluate: Could not load data from https://sat_fqdn


Expected results:
Either stop installation with error message that mentioned variables are set (system wide or just locally) or add support for it.
Comment 1 Chris Roberts 2016-06-24 05:47:48 EDT
Dupe of

https://bugzilla.redhat.com/show_bug.cgi?id=1255247

*** This bug has been marked as a duplicate of bug 1255247 ***

Note You need to log in before you can comment on or make changes to this bug.