Bug 1284503 - Need to update PostgreSQL 9.4 image to handle existing slave data
Need to update PostgreSQL 9.4 image to handle existing slave data
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-postgresql94-docker (Show other bugs)
rh-postgresql94
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 2.2
Assigned To: Pavel Raiskup
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 08:47 EST by Martin Nagy
Modified: 2016-07-26 19:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: rh-postgresql94-docker-9.4-3
Doc Type: Bug Fix
Doc Text:
Previously, when a slave container was terminated while not all container initialization steps were completed, and then a new container was started using the same data, the new container failed. This bug has been fixed by removing the incomplete data directory, and the described problem no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 10:17:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Nagy 2015-11-23 08:47:53 EST
Description of problem:
When a slave is restarted with same volumes, PostgreSQL server won't start.

This was solved in the following PR: https://github.com/openshift/postgresql/pull/82 so all we need is to respin the images with the PR solved.
Comment 1 Martin Nagy 2015-11-23 15:42:04 EST
Just a note, I have created an issue on github for the PostgreSQL image to introduce a better method for solving this problem other than the PR mentioned in the Description. Solving that issue before and introducing that fix into the updated image would be helpful:

https://github.com/openshift/postgresql/issues/84
Comment 5 errata-xmlrpc 2015-12-09 10:17:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2606.html

Note You need to log in before you can comment on or make changes to this bug.