Bug 1284522 - "Error: package lirc-0.9.1a-4.fc21.x86_64 requires lirc-libs(x86-64) = 0.9.1a-4.fc21, but none of the providers can be installed" on attempted upgrade from F21 to F23
"Error: package lirc-0.9.1a-4.fc21.x86_64 requires lirc-libs(x86-64) = 0.9.1a...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alec Leamas
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 09:18 EST by Russell Odom
Modified: 2015-12-28 17:54 EST (History)
6 users (show)

See Also:
Fixed In Version: lirc-0.9.3a-2.fc23 lirc-0.9.2a-3.fc22 lirc-0.9.3a-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 17:54:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2015-11-23 09:18:04 EST
Description of problem:
On upgrade from F21 to F23 with "dnf system-upgrade download --releasever=23", I receive this error:
Error: package lirc-0.9.1a-4.fc21.x86_64 requires lirc-libs(x86-64) = 0.9.1a-4.fc21, but none of the providers can be installed

Version-Release number of selected component (if applicable):
[root@gigalith ~]# rpm -qa | grep lirc
lirc-remotes-0.9.1a-4.fc21.x86_64
lirc-0.9.1a-4.fc21.x86_64
lirc-libs-0.9.1a-4.fc21.x86_64
[root@gigalith ~]# rpm -qa | grep dnf
python2-dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch
dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch
dnf-0.6.4-7.fc21.noarch

How reproducible:
Every try

Steps to Reproduce:
1. Have a Fedora 21 system with "lirc" installed
2. dnf system-upgrade download --releasever=23

Actual results:
[root@gigalith ~]# dnf system-upgrade download --releasever=23
Using metadata from Mon Nov 23 11:03:04 2015 (2:34:46 hours old)
Error: package lirc-0.9.1a-4.fc21.x86_64 requires lirc-libs(x86-64) = 0.9.1a-4.fc21, but none of the providers can be installed

Expected results:
Download starts as expected

Additional info:
I see that between F22 and F23 the "lirc" package has been split up into "lirc-core" and others. Do these not correctly replace the older package? Looks like dnf is incorrectly leaving it behind as there's apparently nothing to upgrade it with.
Comment 1 Michael Schwendt 2015-11-23 18:17:50 EST
The lirc-compat package has been messed up and doesn't cover 0.9.1a but only 0.9.1:

  http://koji.fedoraproject.org/koji/rpminfo?rpmID=6905205

Obsoletes lirc <= 0.9.1
Comment 2 Russell Odom 2015-11-24 05:33:40 EST
Thanks. As a workaround for now I'll uninstall lirc, upgrade Fedora, then install lirc-compat (and restore /etc/lirc/*.rpmsave). I assume the fix is a trivial change to the spec file, so it obsoletes lirc <= 0.9.1a?
Comment 3 Fedora Update System 2015-11-24 10:43:41 EST
lirc-0.9.2a-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-04e120e5f0
Comment 4 Fedora Update System 2015-11-25 07:16:32 EST
lirc-0.9.3a-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b08eb1efe0
Comment 5 Fedora Update System 2015-11-25 21:26:08 EST
lirc-0.9.2a-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update lirc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-04e120e5f0
Comment 6 Fedora Update System 2015-11-25 21:53:52 EST
lirc-0.9.3a-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update lirc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b08eb1efe0
Comment 7 Fedora Update System 2015-12-03 15:20:49 EST
lirc-0.9.3a-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Alec Leamas 2015-12-03 15:32:22 EST
@michael: Thanks!
Comment 9 Fedora Update System 2015-12-03 17:48:37 EST
lirc-0.9.2a-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Mike Holden 2015-12-20 04:16:11 EST
I am seeing this same issue updating from f22 to f23. My current installation includes the packages already discussed above, at the correct up-to-date versions:

[mike@hagrid ~]$ sudo dnf system-upgrade download --releasever=23
Fedora 23 - x86_64 - Updates                                                                    2.6 MB/s |  15 MB     00:05    
Last metadata expiration check performed 0:00:11 ago on Sun Dec 20 20:09:24 2015.
Error: package lirc-0.9.2a-3.fc22.x86_64 requires lirc-libs = 0.9.2a-3.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[mike@hagrid ~]$ rpm -q lirc
lirc-0.9.2a-3.fc22.x86_64

[mike@hagrid ~]$ rpm -q lirc-libs
lirc-libs-0.9.2a-3.fc22.x86_64

As you can see, both lirc and lirc-libs are already updated to the 0.9.2a-3.fc22 releases.
Comment 11 Andreas Kriegl 2015-12-21 10:26:37 EST
Same happens here on x386 system:

Last metadata expiration check performed 1:29:13 ago on Mon Dec 21 14:56:47 2015.
Error: package lirc-0.9.2a-3.fc22.i686 requires lirc-libs = 0.9.2a-3.fc22, but none of the providers can be installed
Comment 12 Alec Leamas 2015-12-21 19:25:14 EST
indeed, the fix in lirc-0.9.3a-2 is broken. Reopening
Comment 13 Fedora Update System 2015-12-21 19:41:58 EST
lirc-0.9.3a-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-233263f33c
Comment 14 Fedora Update System 2015-12-22 19:10:22 EST
lirc-0.9.3a-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-233263f33c
Comment 15 Mike Holden 2015-12-24 18:29:26 EST
I can confirm that last night, I was able to upgrade fc22 -> fc23 by including the updates-testing repository on the command line.

Thanks for the quick turnaround on this one!
Comment 16 Alec Leamas 2015-12-25 05:01:40 EST
@mike: thanks for feedback! Could you please add some karma at [1] so we could push this update ASAP?

[1] https://bodhi.fedoraproject.org/updates/FEDORA-2015-233263f33c
Comment 17 Mike Holden 2015-12-25 08:21:37 EST
Karma added, anonymously, since I don't have an account there!!
Comment 18 Fedora Update System 2015-12-28 17:54:32 EST
lirc-0.9.3a-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.