Bug 1284563 - Searches for user avatars on gravatar cannot be disabled
Searches for user avatars on gravatar cannot be disabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Milan Crha
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 10:16 EST by Simo Sorce
Modified: 2016-11-03 21:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.12.11-17.el7
Doc Type: Bug Fix
Doc Text:
Cause: always tries to get data from gravatar.com Consequence: whenever a mail was shown, evolution asked gravatar.com whether the sender has a picture there (using email hash), which is not always wanted by the users Fix: add an option to enable the search of photos at gravatar.com, which is disabled by default Result: users can decide whether the gravatar.com site is contacted or not
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 730743 None None None Never

  None (edit)
Description Simo Sorce 2015-11-23 10:16:37 EST
If you enable displaying the face header (a picture of the user embedded in headers or the addressbook) then evolution silently also leaks data to gravatar.com in search for a picture of the email sender.
The upstream vertsion has a checkbox to disable searching on gravatar.com, please backport.
Comment 2 Milan Crha 2015-11-23 11:00:47 EST
Thanks for a bug report. I forgot to backport it during the rebase phase, I'm sorry for that. The corresponding upstream bug is [1]. I'd also use a following upstream commit [2].

It also requires translation updates, as the [1] adds new UI strings into Edit->Preferences->Mail Preferences->Headers, the place where the new option to disable gravatar searches can be found.

An alternative interim solution would be to not ship the gravatar module in RHEL for now.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=730743
[2] https://git.gnome.org/browse/evolution/commit/?id=7d28bdf277a
Comment 4 Milan Crha 2016-03-17 04:59:36 EDT
The above patch adds at Edit->Preferences->Mail Preferences->Headers tab, Senders Photo section (at the top), an option:
  [ ] Search gravatar.com for the photograph of sender
which is disabled by default.
Comment 6 Milan Crha 2016-03-21 07:58:14 EDT
I updated the patch for the 3.12.11-17, due to missed .ui file in the package (not locally).
Comment 9 errata-xmlrpc 2016-11-03 21:06:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2228.html

Note You need to log in before you can comment on or make changes to this bug.