Bug 1284569 - Can't replace a build with a more recent one in a bodhi update
Can't replace a build with a more recent one in a bodhi update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
23
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 10:27 EST by Elio Maldonado Batiz
Modified: 2016-09-19 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 20:29:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elio Maldonado Batiz 2015-11-23 10:27:11 EST
Description of problem: Created a Bodhi bundle for the NSS family of packages for fc22. The bundle now on pending is  the one at https://bodhi.fedoraproject.org/updates/FEDORA-2015-ae4c9ec179
Attempts to replace nss-softokn-3.21.0-1.0.fc22 with nss-softokn-3.21.0-1.1.fc22 are failing. 

When bodhi is trying to push this I get the error:

[ bodhi WARNING]f22-updates-testing nspr-4.10.10-2.fc22 nss-3.21.0-1.1.fc22 nss-softokn-3.21.0-1.0.fc22 nss-util-3.21.0-1.0.fc22 ejected from the push because u"Cannot find relevant tag for nss-softokn-3.21.0-1.0.fc22: ['f22-updates-testing-pending']"


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Click o Edit
2. On Packages type nss-softokn and hit enter
3. From the short list that show up check nss-softokn-3.21.0-1.1.fc22
4. Uncheck nss-softokn-3.21.0-1.0.fc22
5. Click on the green Edit button near the button
6. Refresh the page


Actual results: nss-softokn-3.21.0-1.0.fc22 shows up

Expected results: nss-softokn-3.21.0-1.1.fc22 shows up
replacing the previous version


Additional info:
Comment 1 Luke Macken 2015-11-23 12:46:58 EST
https://github.com/fedora-infra/bodhi/pull/700

This issue is related to the corresponding buildroot override for the build that you are trying to remove. It's been fixed in git, and deployed to staging, but we're currently hitting some database issues at the moment. Working on getting this deployed now.
Comment 2 Luke Macken 2015-11-24 20:29:50 EST
This issue should hopefully be resolved with Bodhi 2.1.3, which I just pushed to production. 

https://lists.fedoraproject.org/archives/list/infrastructure%40lists.fedoraproject.org/thread/WJLJGYQYGA5FZJ353GFNNSWLIK5VGWUO/

Please re-open this bug if you still experience this problem. Thanks!

Note You need to log in before you can comment on or make changes to this bug.