Bug 1284583 - Running a long running task from simulate on one web browser Web UI session hangs all other web browser Web UI sessions
Running a long running task from simulate on one web browser Web UI session h...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 10:52 EST by Peter McGowan
Modified: 2018-01-05 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 14:43:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to reproduce the problem (1.37 KB, text/plain)
2015-11-23 10:52 EST, Peter McGowan
no flags Details

  None (edit)
Description Peter McGowan 2015-11-23 10:52:44 EST
Created attachment 1097725 [details]
Script to reproduce the problem

Description of problem:
If I run an automation script from simulate (or from a button) that takes a long time to complete, all other web browser sessions into the Web UI on the same appliance seem to hang until the task has completed.

Version-Release number of selected component (if applicable):
5.4.3.1

How reproducible:

Every time.

Steps to Reproduce:
1. Log into the Web UI on two separate web browser sessions
2. Run the attached script from simulate in one browser session (the script should take several seconds to run, depending on number of database objects). 
3. Try to access the Web UI on the second web browser session while the script is running.

Actual results:
The second web browser session appears to be hung

Expected results:
An automation task run from one web browser session should not affect another separate web browser session.

Additional info:

We are seeing this in a multi-appliance installation. The Web UI appliance has 4 UI Worker threads.
Comment 2 Chris Pelland 2017-06-07 14:43:41 EDT
This BZ has been closed since it was opened on a version of CloudForms that has reached the end of its lifecycle.  If you find that this bug is still relevant, please open a new BZ against the relevant supported version of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.