Bug 128459 - Default /etc/hosts isn't in correct format (alias before canonical_hostname)
Default /etc/hosts isn't in correct format (alias before canonical_hostname)
Status: CLOSED DUPLICATE of bug 128458
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-07-23 02:22 EDT by Mike MacCana
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2004-07-23 02:22:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9

Description of problem:
The default /etc/hosts file isn't in the correct format. According to
'man hosts', our own documentatation, GLS training material, and the
RFC, the format is as follows:

IP_address canonical_hostname aliases

from the man page:
"Aliases  provide  for  name changes, alternate spellings, shorter host-
names, or generic hostnames (for example, localhost)."

Our current file is as follows:       localhost       localhost.localdomain

I.e, the alias is before the canonical hostname.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install RHEL
2.Look at default /etc/hosts file
3.Compare to documentation

Actual Results:  The file is in the wrong format - the alias is in the
first column, the canonical_hostname is in the second.

Expected Results:  The file should be as documented.

Additional info:
Comment 1 Mike MacCana 2004-07-23 02:22:48 EDT

*** This bug has been marked as a duplicate of 128458 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.