Bug 1284609 - KeePass tray icon missing
KeePass tray icon missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Timotheus Pokorra
Fedora Extras Quality Assurance
https://bugzilla.xamarin.com/show_bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 11:20 EST by Florian Kaiser
Modified: 2016-06-27 14:25 EDT (History)
12 users (show)

See Also:
Fixed In Version: mono-4.2.4-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-27 14:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-1 (274.34 KB, image/png)
2015-11-23 11:22 EST, Florian Kaiser
no flags Details
Screenshot-2 (294.57 KB, image/png)
2015-11-23 11:22 EST, Florian Kaiser
no flags Details
Screenshot-TopIcon-1 (277.57 KB, image/png)
2015-11-23 11:23 EST, Florian Kaiser
no flags Details
Screenshot-TopIcon-2 (300.72 KB, image/png)
2015-11-23 11:23 EST, Florian Kaiser
no flags Details

  None (edit)
Description Florian Kaiser 2015-11-23 11:20:44 EST
Description of problem:
KeePass has a black tray icon instead of the actual KeePass icon.

Version-Release number of selected component (if applicable):
2.30

How reproducible:
Always.

Steps to Reproduce:
1. Install KeePass.
2. Optional: activate TopIcons gnome extension: https://extensions.gnome.org/extension/495/topicons/
3. Minimize KeePass to tray.

Actual results:
KeePass has a tray icon but it's just black, not the actual KeePass icon.

Expected results:
KeePass's tray icon should be the actual KeePass icon.
Comment 1 Florian Kaiser 2015-11-23 11:22 EST
Created attachment 1097756 [details]
Screenshot-1
Comment 2 Florian Kaiser 2015-11-23 11:22 EST
Created attachment 1097757 [details]
Screenshot-2
Comment 3 Florian Kaiser 2015-11-23 11:23 EST
Created attachment 1097758 [details]
Screenshot-TopIcon-1
Comment 4 Florian Kaiser 2015-11-23 11:23 EST
Created attachment 1097759 [details]
Screenshot-TopIcon-2
Comment 5 Peter Oliver 2015-11-23 16:56:02 EST
I can reproduce this on x86_64 Fedora 22.  It is upstream Mono bug https://bugzilla.xamarin.com/show_bug.cgi?id=8935.
Comment 6 Habig, Alec 2016-06-23 12:41:30 EDT
Just upgraded to f24 (from f22), and in research why my keepassx icon disappeared, ended up here.  So, can confirm that this bug is still active in the current release.
Comment 7 Timotheus Pokorra 2016-06-23 14:35:46 EDT
I have found now a patch that resolves this issue.
It is mentioned here: https://bugzilla.xamarin.com/show_bug.cgi?id=14976
I will update the mono packages accordingly over the next days.
Comment 8 Habig, Alec 2016-06-23 17:43:44 EDT
Fantastic, thanks!  Thinking ahead to testing out your fix, though: despite being able to run xkeepass happily (in all respects except for that icon), there's not a mono package to be found on my system*.  Or, are there no runtime components but only build-time?  If that's the case, I'll pull the xkeepass SRPM and load up on build reqs for testing.

*"rpm -qa | grep -i mono" returns a few monospaced font files, and that's it :)
Comment 9 Fedora Update System 2016-06-24 01:18:53 EDT
mono-4.2.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dbe5ffa1cc
Comment 10 Timotheus Pokorra 2016-06-24 01:31:05 EDT
@Alec: I think you are confusing two packages: keepassx and keepass. 

https://admin.fedoraproject.org/pkgdb/package/rpms/keepassx/ is not using Mono at all: http://pkgs.fedoraproject.org/cgit/rpms/keepassx.git/tree/keepassx.spec
It is this software: http://www.keepassx.org/

We are talking here about https://admin.fedoraproject.org/pkgdb/package/rpms/keepass/. It is this software: http://keepass.info/
It seems in http://pkgs.fedoraproject.org/cgit/rpms/keepass.git/tree/keepass.spec there is no direct dependancy on Mono for installation. But during the build the dependancy for mono(System) = 4.0.0.0 is picked up automatically. So "dnf install keepass" will always check that Mono is installed as well.

To test keepass with the updated Mono packages, which will go into the updates testing repository within this day, see https://fedoraproject.org/wiki/QA:Updates_Testing
Comment 11 Habig, Alec 2016-06-24 12:46:47 EDT
ahh, that's it.  keepass that uses mono is the newer version, compatible with the windows program but not the android app I need: utilizing the older DB format.  Thus I am using keepassx (specifically, keepassx0), which does not depend upon mono: so it must have a blank icon for other reasons.  Sorry for the confusion: but surely the mono-using people are happy for the bugfix :)
Comment 12 Habig, Alec 2016-06-24 12:53:36 EDT
In fact, a more alert user put in bugzilla 1349348 yesterday for keepassx0, and a patch has already been pushed, and it works.

Hooray for opensource software and a great community!
Comment 13 Fedora Update System 2016-06-24 20:31:39 EDT
mono-4.2.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dbe5ffa1cc
Comment 14 Timotheus Pokorra 2016-06-27 03:13:45 EDT
https://bodhi.fedoraproject.org/users/bollocks writes on Bodhi:

Keepass and Pinta are working good for me and both use Mono. I didn't even know KeePass was supposed to have a tray icon. Something weird seems to be happening. I'm running i3 with i3bar and I see this: http://i.imgur.com/RhDxyaV.png
Clicking on the icon brings up KeePass but usually tray icons end up on the right side like the hexchat icon in the bottom right.

Is this a new bug? What should we do?
Comment 15 Fedora Update System 2016-06-27 14:25:47 EDT
mono-4.2.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.