Bug 1284625 - HA nfs-ganesha with two node
HA nfs-ganesha with two node
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs (Show other bugs)
3.1
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Saurabh
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 12:03 EST by Shawn Houston
Modified: 2016-08-19 05:15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-25 08:26:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Houston 2015-11-23 12:03:47 EST
Description of problem:
if using two nodes for HA nfs-ganesha the corosync conf file is updated within the quorum section with two_node: 1, the correct directive is two_nodes: 1

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. create two node HA nfs-ganesha
2. share a volume with nfs-ganesha
3. stop one of the two gluster nodes

Actual results: corosync halts share


Expected results: corosync is is in two node and fails IP over, service continues


Additional info:
Comment 1 Kaleb KEITHLEY 2015-11-23 13:06:30 EST
Please identify whether this is on RHEL7 or RHEL6.

Nothing in RHGS makes direct changes to /etc/corosync/corosync.conf.

All updates to it are made by running pacemaker command line tools. Any resulting typos are due to the tools or by pacemaker itself.
Comment 2 Shawn Houston 2015-11-23 13:15:33 EST
RHEL 7.1 and 7.2
Comment 4 Jan Friesse 2015-11-24 03:29:15 EST
I don't understand what exactly is problem. Both corosync.conf (RHEL 7) and cman cluster (RHEL 6) has "two_node" directive. Where you found two_nodeS? It's not supported in any version.

Closing it as a not a bug.
Comment 7 Niels de Vos 2016-01-27 06:41:59 EST
Hey Kaleb, you reopened this bug. Does that mean there is a fix needed in out glusterfs-ganesha scripts?
Comment 8 Kaleb KEITHLEY 2016-04-25 08:26:17 EDT
I don't remember why I reopened it. closing, clear needinfo

Note You need to log in before you can comment on or make changes to this bug.