Bug 1284639 - Automate domain and a namespace can't have the same name
Automate domain and a namespace can't have the same name
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
All Linux
low Severity low
: GA
: 5.5.2
Assigned To: mkanoor
Milan Falešník
: ZStream
Depends On: 1281582
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 12:44 EST by Chris Pelland
Modified: 2016-02-10 10:20 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1281582
Environment:
Last Closed: 2016-02-10 10:20:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0159 normal SHIPPED_LIVE CFME 5.5.2 bug fixes and enhancement update 2016-02-10 15:19:02 EST

  None (edit)
Comment 2 CFME Bot 2015-12-07 16:44:01 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1931464fdb00b70222758584a355ba3cb48f031c

commit 1931464fdb00b70222758584a355ba3cb48f031c
Merge: d7cdb55 3bd3d03
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Dec 7 16:43:10 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Dec 7 16:43:10 2015 -0500

    Merge branch 'bugzilla_1284639_5_5_z' into '5.5.z'
    
    Allow for automate namespace and domain to have same names
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1284639
    
    When doing a domain search for instances, if the automate model contains a namespace which has the same name as one of the domains the search returns incorrect results.
    
    Clean Cherry Pick from https://github.com/ManageIQ/manageiq/pull/5417
    
    See merge request !580

 .../engine/miq_ae_domain_search.rb                 |  6 ++--
 .../models/miq_ae_class_copy.rb                    |  3 +-
 .../miq_ae_domain_search_spec.rb                   | 40 ++++++++++++++++++++++
 spec/support/automation_spec_helper.rb             |  1 -
 4 files changed, 46 insertions(+), 4 deletions(-)
Comment 4 Milan Falešník 2016-01-28 03:48:50 EST
Verified in 5.5.2.2. It resolved the relationship properly and I could see the "TEST2/TEST1/CLASS1/INSTANCE1" in the tree on right.
Comment 5 errata-xmlrpc 2016-02-10 10:20:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.