Bug 128465 - Incorrect cursor position when editting
Incorrect cursor position when editting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 05:40 EDT by Toshihiko Shimizu
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 21:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshihiko Shimizu 2004-07-23 05:40:03 EDT
Description of problem:

 Incorrect cursor position handling, when entered the specific
characters.(in japanese environment)
 spacific characters are following:(it will not be all of them)
   . white circle (U-25CB)
   . multiple sign (U-00D7)
   . divide sign (U-00F7)

 Although these characters are full-width size in Japanese environment,
 vim handles them like as half-width size characters.

Version-Release number of selected component (if applicable):

 6.2.457

How reproducible:

 very easy.

Steps to Reproduce:
1. login with X11(Japanese environment)
2. kick kterm
3. invoke vim
4. enter following string in vim
   "xxx**xxx"
   ** means 'White Circle' character enter with canna.
5. move cursor from left end to right end with 'l' key.
   it feels strange result.
  
Actual results:

 stop cursor before end of line.  

Expected results:

 stop cursor *at* end of line.


Additional info:
Comment 1 Toshihiko Shimizu 2004-08-18 21:19:44 EDT
Self solved.

use 'ambiwidth' option as following:

  :set ambiwidth=double

All looks like good.

Note You need to log in before you can comment on or make changes to this bug.