Bug 1284654 - [REST API] product_info/version number is incorrect
Summary: [REST API] product_info/version number is incorrect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-23 19:27 UTC by Brandon Dunne
Modified: 2016-01-11 16:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 06:40:12 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Brandon Dunne 2015-11-23 19:27:37 UTC
Description of problem:
Navigate to REST API to find incorrect information in the version build field.
<api>
  <product_info>
    <name>Red Hat Enterprise Virtualization Manager</name>
    <vendor>Red Hat</vendor>
    <version major="3" minor="5" build="0" revision="0"/>
    <full_version>3.5.5-0.1.el6ev</full_version>
  </product_info>
</api>

Expected results:
<api>
  <product_info>
    <name>Red Hat Enterprise Virtualization Manager</name>
    <vendor>Red Hat</vendor>
    <version major="3" minor="5" build="5" revision="0"/>
    <full_version>3.5.5-0.1.el6ev</full_version>
  </product_info>
</api>

Comment 1 Brandon Dunne 2015-11-23 19:30:54 UTC
I don't see "full_version" in the documentation, so I would expect version to be the correct and reliable source.  

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Technical_Guide/chap-Entry_Point.html#Product_Information

Comment 2 Oved Ourfali 2015-11-24 06:40:12 UTC

*** This bug has been marked as a duplicate of bug 1206068 ***


Note You need to log in before you can comment on or make changes to this bug.