Bug 1284660 - issue: kickstart fails with 3way raid1 array setup on RHEL 7.1
issue: kickstart fails with 3way raid1 array setup on RHEL 7.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.1
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Vratislav Podzimek
Release Test Team
:
Depends On:
Blocks: 1203710 1295926 1313485
  Show dependency treegraph
 
Reported: 2015-11-23 14:43 EST by jcastran
Modified: 2016-11-03 19:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-blivet-0.61.15.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:51:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
7.2-program.log (84.04 KB, text/plain)
2015-12-01 19:26 EST, Arun S A G
no flags Details
7.2-ifcfg.log (4.93 KB, text/plain)
2015-12-01 19:27 EST, Arun S A G
no flags Details
7.2-anaconda.log (3.35 KB, text/plain)
2015-12-01 19:28 EST, Arun S A G
no flags Details
7.2-storage.log (213.07 KB, text/plain)
2015-12-01 19:28 EST, Arun S A G
no flags Details
7.2-partdata - partition kickstart commands (1.02 KB, text/plain)
2015-12-01 19:29 EST, Arun S A G
no flags Details
7.2-storage.state (28.00 KB, text/plain)
2015-12-01 19:30 EST, Arun S A G
no flags Details
7.2-syslog (55.69 KB, text/plain)
2015-12-01 19:30 EST, Arun S A G
no flags Details

  None (edit)
Description jcastran 2015-11-23 14:43:21 EST
Description of problem:
it complains about insufficient disks only when i try to create raid level 1 across more than 2 disk partitions using kickstart file. (see logs boot_3on6_rh7.tgz (63.3 kB))
Creating raid 1 across 2 disk partitions works fine (see logs raid-2on2_rh7_logs.tgz (59.0 kB) )

Version-Release number of selected component (if applicable):
7.1

Actual results:
 ERR anaconda: storage configuration failed: not enough space for LVM requests
 INFO anaconda: fs space: 0 B  needed: 1524.54 MiB

Expected results:
 Space is available and installable

Additional info:
  > Not enough space in file systems for the current software selection. An additional 1524.54 MiB is needed.

In anaconda.log:
23:05:29,005 ERR anaconda: storage configuration failed: not enough space for LVM requests
23:05:33,688 INFO anaconda: fs space: 0 B  needed: 1524.54 MiB

The needed size almost matches the os image specified in liveimg kickstart command.

In packaging.log:
23:05:26,741 DEBUG packaging: liveimg size is 1598596032


The related code:
        free = Size(self.storage.fileSystemFreeSpace)
        needed = self.payload.spaceRequired
        log.info("fs space: %s  needed: %s", free, needed)

------------
def growLVM(storage):
    """ Grow LVs according to the sizes of the PVs.

        Strategy for growth involving thin pools:
            - Applies to device factory class as well.
            - Overcommit is not allowed.
            - Pool lv's base size includes sizes of thin lvs within it.
            - Pool is grown along with other non-thin lvs.
            - Thin lvs within each pool are grown separately using the
              ThinPoolChunk class.
    """
    for vg in storage.vgs:
        total_free = vg.freeSpace
        if total_free < 0:
            # by now we have allocated the PVs so if there isn't enough
            # space in the VG we have a real problem
            raise PartitioningError(_("not enough space for LVM requests"))
        elif not total_free:
            log.debug("vg %s has no free space", vg.name)
            continue
Comment 2 Brian Lane 2015-11-24 19:29:46 EST
Please retry with RHEL7.2, and if it still fails attach the logs from /tmp/*log as individual text/plain attachments.
Comment 3 Arun S A G 2015-12-01 19:26 EST
Created attachment 1101171 [details]
7.2-program.log
Comment 4 Arun S A G 2015-12-01 19:27 EST
Created attachment 1101173 [details]
7.2-ifcfg.log
Comment 5 Arun S A G 2015-12-01 19:28 EST
Created attachment 1101175 [details]
7.2-anaconda.log
Comment 6 Arun S A G 2015-12-01 19:28 EST
Created attachment 1101179 [details]
7.2-storage.log
Comment 7 Arun S A G 2015-12-01 19:29 EST
Created attachment 1101181 [details]
7.2-partdata -  partition kickstart commands
Comment 8 Arun S A G 2015-12-01 19:30 EST
Created attachment 1101182 [details]
7.2-storage.state
Comment 9 Arun S A G 2015-12-01 19:30 EST
Created attachment 1101183 [details]
7.2-syslog
Comment 10 David Lehman 2015-12-02 09:26:27 EST
This is caused by the code in LVMVolumeGroupDeviec.freeSpace which adds padding for lvm-on-raid. It adds 5 extents for each disk (there are three) in the raid. The user chose a 32 MiB extent size, so each new LV (there are three) uses an extra 480MiB in the VG. The result is that the VG (in blivet's model) runs out of space sooner than it should.
Comment 11 Arun S A G 2015-12-03 21:37:28 EST
What is the workaround here? Will reducing the extent size help? Like say 4MB?
Comment 12 Vratislav Podzimek 2015-12-04 07:45:34 EST
(In reply to Arun S A G from comment #11)
> What is the workaround here? Will reducing the extent size help? Like say
> 4MB?

Yes, that should help. The real fix here is to improve calculations of VG free space in Blivet like we did on master/rawhide.
Comment 13 Vratislav Podzimek 2016-04-06 04:47:53 EDT
Ported fixes from the master branch are proposed for the rhel7-branch as:
https://github.com/rhinstaller/blivet/pull/358
Comment 14 Vratislav Podzimek 2016-04-08 03:47:04 EDT
(In reply to Vratislav Podzimek from comment #13)
> Ported fixes from the master branch are proposed for the rhel7-branch as:
> https://github.com/rhinstaller/blivet/pull/358

Merged.
Comment 18 errata-xmlrpc 2016-11-03 19:51:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2168.html

Note You need to log in before you can comment on or make changes to this bug.