Bug 1284663 - Cannot update libical with XFCE desktop installed
Cannot update libical with XFCE desktop installed
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: xfce4-panel (Show other bugs)
epel7
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 15:06 EST by Louis Abel
Modified: 2015-12-26 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-26 18:24:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Louis Abel 2015-11-23 15:06:08 EST
Description of problem:
When attempting to run a update on a RHEL 7.1 machine to move to 7.2, it fails with dependency issues between orage and libical. Libical was upgraded to 1.0.1 from 0.48. This is also more than likely a problem with numerous other packages as well. 

Version-Release number of selected component (if applicable):
libical 0.48 upgraded to => 1.0.1
orage 4.10.0

How reproducible:
Always

Steps to Reproduce:
1. EPEL repository on RHEL 7 machine with XFCE desktop installed
2. Attempt yum update to bring RHEL 7.1 to 7.2

Actual results:
--> Finished Dependency Resolution
Error: Package: orage-4.10.0-4.el7.x86_64 (@epel)
           Requires: libicalss.so.0()(64bit)
           Removing: libical-0.48-6.el7.x86_64 (@rhel-x86_64-server-7)
               libicalss.so.0()(64bit)
           Updated By: libical-1.0.1-1.el7.x86_64 (rhel-x86_64-server-7)
              ~libicalss.so.1()(64bit)
Error: Package: orage-4.10.0-4.el7.x86_64 (@epel)
           Requires: libical.so.0()(64bit)
           Removing: libical-0.48-6.el7.x86_64 (@rhel-x86_64-server-7)
               libical.so.0()(64bit)
           Updated By: libical-1.0.1-1.el7.x86_64 (rhel-x86_64-server-7)
              ~libical.so.1()(64bit)
Error: Package: orage-4.10.0-4.el7.x86_64 (@epel)
           Requires: libicalvcal.so.0()(64bit)
           Removing: libical-0.48-6.el7.x86_64 (@rhel-x86_64-server-7)
               libicalvcal.so.0()(64bit)
           Updated By: libical-1.0.1-1.el7.x86_64 (rhel-x86_64-server-7)
              ~libicalvcal.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Completed yum update.

Additional info:
Numerous packages may need to be rebuilt, including claws-mail, zarafa, smesh, rubygem-openscap, orange, libmapi kmymoney, gnokii, dragonegg. This may not be the extensive list but should be evaluated. Orage was the first package that came out as an "issue" because it's part of the @xfce default packages. xfce4-panel was described as the component for this reason.
Comment 1 Mukundan Ragavan 2015-11-23 17:16:25 EST
You are probably spot on. Can you try this scratch build?

https://koji.fedoraproject.org/koji/taskinfo?taskID=11958040

Depending on this result, I can rebuild the other packages also.
Comment 2 Louis Abel 2015-11-23 18:56:26 EST
I went and tested the scratch build. Both of these methods worked, testing on two different machines:

Test machine 1...
1. Uninstall orage
2. Update system
3. Install scratch RPM with success

Test machine 2...
1. Uninstall orage
2. Install orage from rpm using yum
  -> This causes a bulk of the updates from 7.1 to 7.2 to be pulled in as a result
  -> This still succeeds
Comment 3 Fedora Update System 2015-12-07 17:27:19 EST
orage-4.10.0-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-5e8db1a33a
Comment 4 Fedora Update System 2015-12-08 02:21:33 EST
orage-4.10.0-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update orage'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-5e8db1a33a
Comment 5 Fedora Update System 2015-12-26 18:24:48 EST
orage-4.10.0-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.