Bug 1284678 - add createtraces option to nfstest
add createtraces option to nfstest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfstest (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
Milan Navratil
: FutureFeature, Rebase
: 1130977 (view as bug list)
Depends On: 1244918
Blocks: 1313485 1295577
  Show dependency treegraph
 
Reported: 2015-11-23 16:33 EST by Steve Dickson
Modified: 2016-11-03 18:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: nfstest-2.1.1-0.0.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1244918
Environment:
Last Closed: 2016-11-03 18:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2015-11-23 16:33:55 EST
+++ This bug was initially created as a clone of Bug #1244918 +++

Description of problem:
nfstest tool is not able to generate the tcpdump for some tests. createtraces option is not available in recent version of nfstest for fedora.

Version-Release number of selected component (if applicable):
fedora 22
NFStest-1.0.10 

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:
Its not have the createtraces option.

Expected results:
It should have the createtraces option

Additional info: 
createtraces option is available in nfstest tool. Below link can be refer for it.
http://git.linux-nfs.org/?p=mora/nfstest.git;a=summary

--- Additional comment from Steve Dickson on 2015-11-20 10:03:33 EST ---

(In reply to VIKRANT from comment #0)
> Description of problem:
> nfstest tool is not able to generate the tcpdump for some tests.
> createtraces option is not available in recent version of nfstest for fedora.
> 
> Version-Release number of selected component (if applicable):
> fedora 22
> NFStest-1.0.10 
> 
The latest version in f22 is NFStest-1.0.11-0 so please
do an update. 

> Additional info: 
> createtraces option is available in nfstest tool. Below link can be refer
> for it.
> http://git.linux-nfs.org/?p=mora/nfstest.git;a=summary
I'll check with the maintainer to see if there is a 
new release.

--- Additional comment from Jorge Mora on 2015-11-23 13:18:22 EST ---

The latest release is v2.1.1, get the latest from the
git repository:
http://git.linux-nfs.org/?p=mora/nfstest.git;a=summary

or the tarball at:
http://wiki.linux-nfs.org/wiki/index.php/NFStest#Download

--- Additional comment from Fedora Update System on 2015-11-23 15:19:42 EST ---

NFStest-2.1.1-0.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-641995fc8e
Comment 4 Steve Dickson 2016-01-21 14:52:23 EST
Too early to do the errata... I didn't get the choice...
Comment 5 Steve Dickson 2016-02-11 11:23:16 EST
*** Bug 1130977 has been marked as a duplicate of this bug. ***
Comment 7 Yin.JianHong 2016-05-17 03:32:12 EDT
Verified:

yjh@dhcp-12-106:~/nfstest$ nfstest_dio  -h|grep createtraces
    --createtraces       Create a packet trace for each test
yjh@dhcp-12-106:~/nfstest$ nfstest_delegation  -h|grep createtraces
    --createtraces       Create a packet trace for each test    
yjh@dhcp-12-106:~/nfstest$ nfstest_pnfs  -h|grep createtraces
    --createtraces       Create a packet trace for each test
yjh@dhcp-12-106:~/nfstest$ nfstest_posix  -h|grep createtraces
    --createtraces       Create a packet trace for each test
yjh@dhcp-12-106:~/nfstest$ rpm -q nfstest 
nfstest-2.1.1-0.0.el7.noarch
Comment 11 errata-xmlrpc 2016-11-03 18:54:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2147.html

Note You need to log in before you can comment on or make changes to this bug.