Bug 128471 - ksh RPM should obsoletes: ksh93
Summary: ksh RPM should obsoletes: ksh93
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.17
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-23 12:29 UTC by Brian Long
Modified: 2007-04-18 17:09 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 16:58:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Long 2004-07-23 12:29:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040204

Description of problem:
The component "ksh" is not available in bugzilla.  This applies to ksh
found in the Q3 Errata beta.  There has been a publicly available
"ksh93" rpm for years.  Many folks have replaced "pdksh" in RHEL 3
with the ksh93 rpm.  Since Red Hat chose to include ksh-2004 in this
update, please update the SPEC file to "Obsoletes: ksh93".  This way
your ksh RPM provides a proper upgrade path from the older
public-domain ksh93 RPM.  Thanks!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -U ksh-2004*.rpm
2.
3.
    

Actual Results:  Tries to install conflicting files with the ksh93 RPM.

Expected Results:  Upgrades the existing ksh93 RPM.

Additional info:

Comment 1 Brian Long 2004-07-28 19:37:54 UTC
How does one properly log a bug against things in the RHEL "Extras" or
"Extras Beta" channels?  ksh is included in the RHEL 3 U3 Extras Beta
channel and I'd like to see the RPM "obsoletes: ksh93".  THanks.

Comment 2 David Lawrence 2004-09-13 16:58:33 UTC
Added ksh component to RHEL Bugzilla product.


Note You need to log in before you can comment on or make changes to this bug.