Bug 1284731 - rhcert 2.0 release kdump nfs test cannot run on RHEL6.0 [NEEDINFO]
rhcert 2.0 release kdump nfs test cannot run on RHEL6.0
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-23 22:40 EST by Adam Ru
Modified: 2017-02-06 09:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-06 09:47:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
aru: needinfo? (gcase)


Attachments (Terms of Use)

  None (edit)
Description Adam Ru 2015-11-23 22:40:06 EST
Description of problem:

we noticed the kdump nfs test always failed run on RHEL6.0 (and 6.2) with the rhcert2.0 release (redhat-certification-hardware-1.6.6-20150901.el6.noarch)
after some investigation we found the new kdump test will use "nfs" keyword in the /etc/kdump.conf for the test
e.g
nfs 10.20.175.42:/export/crash

while the kdump in the RHEL6.0 (and 6.2) will not recognize the "nfs" and result a failure when restart the kdump service.

below is some failure output.

[root@promb-gen2-dhcp85 ~]# uname -a
Linux promb-gen2-dhcp85.eng.vmware.com 2.6.32-220.el6.x86_64 #1 SMP Wed Nov 9 08:03:13 EST 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@promb-gen2-dhcp85 ~]# service kdump restart
Stopping kdump:                                            [  OK  ]
Detected change(s) the following file(s):

  /etc/kdump.conf
Rebuilding /boot/initrd-2.6.32-220.el6.x86_64kdump.img
Unknown parameter  nfs
Failed to run mkdumprd
Starting kdump:                                            [FAILED]



Version-Release number of selected component (if applicable):


How reproducible:

run the kdump nfs test on RHEL6.0 (or6.2)

Actual results:

the kdump nfs test will always failed with message "Unknown parameter  nfs"


Additional info:

the redhat certification package info

[root@promb-gen2-dhcp85 ~]# rpm -qa | grep redhat-certification
redhat-certification-hardware-1.6.6-20150901.el6.noarch
redhat-certification-information-1.6.6-20150901.el6.noarch
redhat-certification-backend-2.0-20151117.el6.noarch

the kdump version info (this is the RHEL6.2 inbox)

[root@promb-gen2-dhcp85 ~]# rpm -qf /etc/kdump.conf
kexec-tools-2.0.0-209.el6.x86_64
Comment 1 Adam Ru 2015-11-26 06:31:19 EST
using the previous 1.6.5.2 

hwcert-client-1.6.5.2-20141028.el6.noarch.rpm

the kdump nfs test works fine.
Comment 2 Adam Ru 2016-05-26 04:53:09 EDT
hello redhat

I didn't see this bug been fix in the latest test kit. this bug will block the kdump testing on the RHEL6.0.


-Adam

below is the latest testkit release notes

We are pleased to announce the general availability (GA) of version
1.6.6-20160415.el6 of the Red Hat Certification Hardware Test Suite.
The new version of the test suite *is* an official release and should be used for new Red Hat Enterprise Linux 6.x hardware certification submissions. All new certification requests must be performed using version 2.x of the test suite.

Highlights of the new version include:
* 20GigEthernet test added
* 25GigEthernet test added
* Automatic detection and identification of wireless AC interfaces has been updated to be more reliable.
* fv tests were updated to use rhcert-backend replacing the use of hwcert-backend
* new (optional) -preview package was created
* fv_storage test moved to -preview package
* fv_network test moved to -preview package
* automatic test planning for fv_network re-enabled in -preview package
* Generic Ethernet test created in -preview package
* 50GigEthernet test created in -preview package
* 100GigEthernet test created in -preview package
Comment 3 Adam Ru 2016-05-26 04:59:13 EDT
I believe this is a test script defect. the fix should in next GA testkit for RHEL6.x
Comment 4 Adam Ru 2016-05-26 05:04:23 EDT
Hi Greg 

I saw you are the author for the kdump.py 

# Author: Greg Nichols <gnichols@redhat.com>

could you take a look and give some comments?

thanks

Adam
Comment 6 Adam Ru 2016-05-26 09:07:11 EDT
Hi Gary

May I raise your attention for this bug?

thanks
Adam
Comment 9 Gary Case 2016-06-06 13:28:49 EDT
Hi Adam,

It looks like the issue here is in the way the kexec tools package labels things. It used to use "net", and now it uses "nfs". 

https://access.redhat.com/solutions/6038#dumptargets-nfs

The cert team is looking to fix this, possibly with a patch to detect the installed version of the kexec-tools package and then use the appropriate options. I'm checking to see if you could simply update the version of kexec-tools and run the NFS kdump test and have those results satisfy the cert requirements.

Note You need to log in before you can comment on or make changes to this bug.